• Home
  • Raw
  • Download

Lines Matching refs:transformation

31  To create a transformation matrix that performs two transformations at once,
32 multiply the two source matrices, with the first transformation as the right
33 argument. E.g. to create a transformation matrix that applies the
34transformation s1 followed by s2, call <code>rsMatrixLoadMultiply(&amp;combined, &amp;s2, &amp;s1)…
37 We have two style of functions to create transformation matrices:
39 style simply stores the transformation matrix in the first argument. The latter
40 modifies a pre-existing transformation matrix so that the new transformation
292 To combine two 4x4 transformaton matrices, multiply the second transformation matrix
293 by the first transformation matrix. E.g. to create a transformation matrix that applies
294 …the transformation s1 followed by s2, call <code>rsMatrixLoadMultiply(&amp;combined, &amp;s2, &amp…
398 When combining two 4x4 transformation matrices using this function, the resulting
399 matrix will correspond to performing the rhs transformation first followed by
400 the original m transformation.
518 summary: Apply a rotation to a transformation matrix
522 This function modifies a transformation matrix to first do a rotation. The axis of
525 To apply this combined transformation to a vector, multiply the vector by the created
536 summary: Apply a scaling to a transformation matrix
540 This function modifies a transformation matrix to first do a scaling. When scaling,
543 To apply this combined transformation to a vector, multiply the vector by the created
569 summary: Apply a translation to a transformation matrix
573 This function modifies a transformation matrix to first do a translation. When
576 To apply this combined transformation to a vector, multiply the vector by the