Lines Matching refs:constexpr
17 constexpr Literal() {} in Literal()
31 constexpr T();
32 constexpr int f() const;
35 …virtual constexpr int ExplicitlyVirtual() const { return 0; } // expected-error {{virtual function… in ExplicitlyVirtual()
37 …constexpr int ImplicitlyVirtual() const { return 0; } // expected-error {{virtual function cannot … in ImplicitlyVirtual()
39 …virtual constexpr int OutOfLineVirtual() const; // expected-error {{virtual function cannot be con…
42 …constexpr NonLiteral NonLiteralReturn() const { return {}; } // expected-error {{constexpr functio… in NonLiteralReturn()
43 constexpr void VoidReturn() const { return; } in VoidReturn()
47 constexpr ~T(); // expected-error {{destructor cannot be marked constexpr}}
49 constexpr F NonLiteralReturn2; // ok until definition
52 …constexpr int NonLiteralParam(NonLiteral) const { return 0; } // expected-error {{constexpr functi… in NonLiteralParam()
54 constexpr G NonLiteralParam2; // ok until definition
57 constexpr int Deleted() const = delete;
64 constexpr T &operator=(const T&) = default;
73 constexpr int T::OutOfLineVirtual() const { return 0; } in OutOfLineVirtual()
77 constexpr T2 &operator=(const T2&) = default; // ok
80 constexpr T3 &operator=(const T3&) const = default;
85 constexpr U SelfReturn() const;
86 constexpr int SelfParam(U) const;
90 …constexpr int F() const { return 0; } // expected-error {{constexpr member function not allowed in… in F()
94 constexpr int AllowedStmtsCXX11() { in AllowedStmtsCXX11()
121 constexpr int DisallowedStmtsCXX1Y_1() { in DisallowedStmtsCXX1Y_1()
126 constexpr int DisallowedStmtsCXX1Y_2() { in DisallowedStmtsCXX1Y_2()
132 constexpr int DisallowedStmtsCXX1Y_3() { in DisallowedStmtsCXX1Y_3()
137 constexpr int DisallowedStmtsCXX1Y_4() { in DisallowedStmtsCXX1Y_4()
142 constexpr int DisallowedStmtsCXX1Y_5() { in DisallowedStmtsCXX1Y_5()
144 …static constexpr int n = 123; // expected-error {{static variable not permitted in a constexpr fun… in DisallowedStmtsCXX1Y_5()
147 constexpr int DisallowedStmtsCXX1Y_6() { in DisallowedStmtsCXX1Y_6()
149 …thread_local constexpr int n = 123; // expected-error {{thread_local variable not permitted in a c… in DisallowedStmtsCXX1Y_6()
152 constexpr int DisallowedStmtsCXX1Y_7() { in DisallowedStmtsCXX1Y_7()
158 constexpr int ForStmt() { in ForStmt()
165 constexpr int VarDecl() { in VarDecl()
172 constexpr int ConstexprVarDecl() { in ConstexprVarDecl()
173 constexpr int a = 0; in ConstexprVarDecl()
179 constexpr int VarWithCtorDecl() { in VarWithCtorDecl()
187 constexpr NonLiteral &ExternNonLiteralVarDecl() { in ExternNonLiteralVarDecl()
195 constexpr int FuncDecl() { in FuncDecl()
196 constexpr int ForwardDecl(int); in FuncDecl()
202 constexpr int ClassDecl1() { in ClassDecl1()
209 constexpr int ClassDecl2() { in ClassDecl2()
216 constexpr int ClassDecl3() { in ClassDecl3()
223 constexpr int NoReturn() {} // expected-error {{no return statement in constexpr function}} in NoReturn()
224 constexpr int MultiReturn() { in MultiReturn()
240 constexpr int f(int k) { in f()
245 constexpr int f() { // expected-error {{constexpr function never produces a constant expression}} in f()
267 constexpr int square(int x) { in square()
270 constexpr long long_max() { in long_max()
273 constexpr int abs(int x) { in abs()
281 constexpr int first(int n) { in first()
285 constexpr int uninit() { in uninit()
289 constexpr int prev(int x) { in prev()
296 constexpr int g(int x, int n) { in g()