• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1Summary: hello2 -- double hello, world rpm
2Name: hello2
3Version: 1.0
4Release: 2
5Group: Utilities
6License: GPL
7Distribution: RPM ^W Elfutils test suite.
8Vendor: Red Hat Software
9Packager: Red Hat Software <bugs@redhat.com>
10URL: http://www.redhat.com
11BuildRequires: gcc make
12Source0: hello-1.0.tar.gz
13
14%description
15Simple rpm demonstration with an eye to consumption by debuginfod.
16
17%package two
18Summary: hello2two
19License: GPL
20
21%description two
22Dittoish.
23
24%prep
25%setup -q -n hello-1.0
26
27%build
28gcc -g -O1 hello.c -o hello
29gcc -g -O2 -D_FORTIFY_SOURCE=2 hello.c -o hello2
30
31%install
32rm -rf $RPM_BUILD_ROOT
33mkdir -p $RPM_BUILD_ROOT/usr/local/bin
34cp hello $RPM_BUILD_ROOT/usr/local/bin/
35cp hello2 $RPM_BUILD_ROOT/usr/local/bin/
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%files
41%defattr(-,root,root)
42%attr(0751,root,root)   /usr/local/bin/hello
43
44%files two
45%defattr(-,root,root)
46%attr(0751,root,root)   /usr/local/bin/hello2
47
48%changelog
49* Thu Nov 14 2019 Frank Ch. Eigler <fche@redhat.com>
50- Added source code right here to make spec file self-contained.
51- Dropped misc files not relevant to debuginfod testing.
52
53* Wed May 18 2016 Mark Wielaard <mjw@redhat.com>
54- Add hello2 for dwz testing support.
55
56* Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
57- create.
58