Lines Matching refs:noexcept
29 void f1() noexcept { } in f1()
30 void f2() noexcept (true) { } in f2()
31 void f3() noexcept (false) { } in f3()
32 void f4() noexcept (1 < 2) { } in f4()
35 void foo() noexcept { } in foo()
36 void bar() noexcept (true) { } in bar()
39 void (*fptr1)() noexcept;
40 void (*fptr2)() noexcept (true);
46 void f() throw(int) noexcept { } // expected-error {{cannot have both}} in f()
47 void g() noexcept throw(int) { } // expected-error {{cannot have both}} in g()
57 void g1() noexcept(A()); // expected-error {{not contextually convertible}}
58 …void g2(bool b) noexcept(b); // expected-error {{argument to noexcept specifier must be a constant…
68 void g(T x) noexcept((sizeof(T) == sizeof(int)) || noexcept(f(x))) { } in g()
77 …static int f() noexcept(1/X) { return 10; } // expected-error{{argument to noexcept specifier mus… in f()
81 …int (*p)() noexcept(1/X); // expected-error{{argument to noexcept specifier must be a constant exp… in f()