Lines Matching refs:NonLiteral
12 struct NonLiteral { // expected-note 3{{no constexpr constructors}} struct
13 NonLiteral() {} in NonLiteral() function
14 NonLiteral(int) {} in NonLiteral() argument
30 struct T : SS, NonLiteral {
42 …constexpr NonLiteral NonLiteralReturn() const { return {}; } // expected-error {{constexpr functio… in NonLiteralReturn()
48 typedef NonLiteral F() const;
52 …constexpr int NonLiteralParam(NonLiteral) const { return 0; } // expected-error {{constexpr functi… in NonLiteralParam()
53 typedef int G(NonLiteral) const;
139 …NonLiteral nl; // expected-error {{variable of non-literal type 'NonLiteral' cannot be defined in … in DisallowedStmtsCXX1Y_4()
186 NonLiteral nl;
187 constexpr NonLiteral &ExternNonLiteralVarDecl() { in ExternNonLiteralVarDecl()
188 extern NonLiteral nl; in ExternNonLiteralVarDecl()