Lines Matching refs:X2
61 struct X2 { struct
76 T X2<T, U>::static_member1 = 17; // expected-error{{cannot initialize}} argument
79 U X2<T, U>::static_member2; // expected-error{{no matching}}
81 template void X2<int, float>::f(int &, float);
82 template void X2<int, float>::f(int &, double); // expected-error{{does not refer}}
83 template void X2<int, int*>::f(int&, int*); // expected-note{{instantiation}}
85 template struct X2<int, float>::Inner;
86 template struct X2<int, Incomplete>::Inner; // expected-note{{instantiation}}
88 template int X2<int, float>::static_member1;
89 template int* X2<int*, float>::static_member1; // expected-note{{instantiation}}
91 NonDefaultConstructible X2<NonDefaultConstructible, int>::static_member1;
94 …NonDefaultConstructible X2<int, NonDefaultConstructible>::static_member2; // expected-note{{instan…