• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1define(MULTIARCH_HEADERS,ifdef(`DO_MULTIARCH',
2Multi-Arch: same
3Pre-Depends: ${misc:Pre-Depends},REMOVE_ME))dnl
4define(UTIL_LINUX_NG_DEFINES,
5ifdef(`UTIL_LINUX_NG', ``libblkid-dev (>= 2.16), uuid-dev (>= 2.16),''))dnl
6Source: e2fsprogs
7Section: admin
8Priority: required
9Maintainer: Theodore Y. Ts'o <tytso@mit.edu>
10Build-Depends: gettext, texinfo, pkg-config, gcc-multilib [mips mipsel], libfuse-dev [linux-any kfreebsd-any], libattr1-dev, debhelper (>= 9.0), UTIL_LINUX_NG_DEFINES m4
11Standards-Version: 3.9.8
12Homepage: http://e2fsprogs.sourceforge.net
13
14ifdef(`FUSE2FS',``
15Package: fuse2fs
16Priority: optional
17Depends: ${shlibs:Depends}, ${misc:Depends}
18Architecture: linux-any kfreebsd-any
19Description: ext2 / ext3 / ext4 file system driver for FUSE
20 fuse2fs is a FUSE file system client that supports reading and
21 writing from devices or image files containing ext2, ext3, and ext4
22 file systems.
23'')dnl
24
25ifdef(`E2FSCK_STATIC',``
26Package: e2fsck-static
27Priority: optional
28Depends: ${misc:Depends}
29Recommends: sash | bash-static | zsh-static | busybox-static | zsh30-static
30Architecture: any
31Description: statically-linked version of the ext2/ext3/ext4 filesystem checker
32 This may be of some help to you if your filesystem gets corrupted enough
33 to break the shared libraries used by the dynamically linked checker.
34 .
35 This binary takes much more space than its dynamic counterpart located
36 in e2fsprogs, though.
37 .
38 You may want to install a statically-linked shell as well, to be able
39 to run this program if something like your C library gets corrupted.
40'')dnl
41
42Package: libcomerr2
43Section: libs
44Provides: libcomerr-kth-compat
45Depends: ${shlibs:Depends}, ${misc:Depends}
46Replaces: e2fsprogs (<< 1.34-1)
47Architecture: any
48MULTIARCH_HEADERS
49Description: common error description library
50 libcomerr is an attempt to present a common error-handling mechanism to
51 manipulate the most common form of error code in a fashion that does not
52 have the problems identified with mechanisms commonly in use.
53
54Package: comerr-dev
55Section: libdevel
56Priority: extra
57Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary}), ${misc:Depends}
58Suggests: doc-base
59Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
60Architecture: any
61Description: common error description library - headers and static libraries
62 libcom_err is an attempt to present a common error-handling mechanism to
63 manipulate the most common form of error code in a fashion that does not
64 have the problems identified with mechanisms commonly in use.
65 .
66 This package contains the development environment for the com_err library.
67
68Package: libss2
69Section: libs
70Depends: libcomerr2, ${shlibs:Depends}, ${misc:Depends}
71Replaces: e2fsprogs (<< 1.34-1)
72Architecture: any
73MULTIARCH_HEADERS
74Description: command-line interface parsing library
75 libss provides a simple command-line interface parser which will
76 accept input from the user, parse the command into an argv argument
77 vector, and then dispatch it to a handler function.
78 .
79 It was originally inspired by the Multics SubSystem library.
80
81Package: ss-dev
82Section: libdevel
83Priority: extra
84Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev, ${misc:Depends}
85Architecture: any
86Description: command-line interface parsing library - headers and static libraries
87 This package includes a tool that parses a command table to generate
88 a simple command-line interface parser, the include files needed to
89 compile and use it, and the static libs.
90 .
91 It was originally inspired by the Multics SubSystem library.
92 .
93 This package contains the development environment for the ss library.
94ifdef(`UTIL_LINUX_NG',,``
95Package: libuuid1
96Section: libs
97Depends: passwd, ${shlibs:Depends}, ${misc:Depends}
98Recommends: uuid-runtime
99Replaces: e2fsprogs (<< 1.34-1)
100Architecture: any
101MULTIARCH_HEADERS
102Description: Universally Unique ID library
103 The libuuid library generates and parses 128-bit universally unique
104 ids (UUIDs).  A UUID is an identifier that is unique across both
105 space and time, with respect to the space of all UUIDs.  A UUID can
106 be used for multiple purposes, from tagging objects with an extremely
107 short lifetime, to reliably identifying very persistent objects
108 across a network.
109 .
110 See RFC 4122 for more information.
111
112Package: uuid-runtime
113Section: libs
114Priority: optional
115Depends: passwd, libuuid1 (>> 1.40.3-1), ${shlibs:Depends}, ${misc:Depends}
116Replaces: e2fsprogs (<= 1.40.3-1ubuntu1)
117Architecture: any
118Description: runtime components for the Universally Unique ID library
119 The libuuid library generates and parses 128-bit universally unique
120 ids (UUIDs).  A UUID is an identifier that is unique across both
121 space and time, with respect to the space of all UUIDs.  A UUID can
122 be used for multiple purposes, from tagging objects with an extremely
123 short lifetime, to reliably identifying very persistent objects
124 across a network.
125 .
126 See RFC 4122 for more information.
127 .
128 This package contains the uuidgen program and the uuidd daemon.
129 .
130 The uuidd daemon is used to generate UUIDs, especially time-based
131 UUID’s, in a secure and guaranteed-unique fashion, even in the face
132 of large numbers of threads trying to grab UUID’s running on
133 different CPU’s. It is used by libuuid as well as the uuidgen
134 program.
135
136ifdef(`UDEB_PKGS',``
137Package: libuuid1-udeb
138Package-Type: udeb
139Section: debian-installer
140Priority: optional
141Depends: ${shlibs:Depends}
142Architecture: any
143Description: stripped down universally unique id library, for debian-installer
144 libuuid generates and parses 128-bit universally unique ids (UUIDs).
145 See RFC 4122 for more information.
146 .
147 This is a minimal package for debian-installer.
148'')dnl
149
150Package: uuid-dev
151Section: libdevel
152Priority: extra
153Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary}), ${misc:Depends}
154Replaces: e2fslibs-dev (<< 1.15)
155Architecture: any
156Description: universally unique id library - headers and static libraries
157 libuuid generates and parses 128-bit universally unique ids (UUIDs).
158 See RFC 4122 for more information.
159 .
160 This package contains the development environment for the uuid library.
161
162Package: libblkid1
163Section: libs
164Depends: ${shlibs:Depends}, ${misc:Depends}
165Architecture: any
166Description: block device id library
167 The blkid library which allows system programs like fsck and
168 mount to quickly and easily find block devices by filesystem UUID and
169 LABEL.  This allows system administrators to avoid specifying
170 filesystems by hard-coded device names, but via a logical naming
171 system instead.
172
173ifdef(`UDEB_PKGS',``
174Package: libblkid1-udeb
175Package-Type: udeb
176Section: debian-installer
177Priority: optional
178Depends: ${shlibs:Depends}, ${misc:Depends}
179Architecture: any
180Description: stripped down block device id library, for debian-installer
181 The blkid library which allows system programs like fsck and
182 mount to quickly and easily find block devices by filesystem UUID and
183 LABEL.  This allows system administrators to avoid specifiying
184 filesystems by hard-coded device names, but via a logical naming
185 system instead.
186 .
187 This is a minimal package for debian-installer.
188'')dnl
189
190Package: libblkid-dev
191Section: libdevel
192Priority: extra
193Depends: libc6-dev | libc-dev, libblkid1 (= ${binary:Version}), ${misc:Depends}
194Architecture: any
195Description: block device id library - headers and static libraries
196 The blkid library which allows system programs like fsck and
197 mount to quickly and easily find block devices by filesystem UUID and
198 LABEL.  This allows system administrators to avoid specifiying
199 filesystems by hard-coded device names, but via a logical naming
200 system instead.
201 .
202 This package contains the development environment for the blkid library.
203'')dnl
204
205ifdef(`UDEB_PKGS',``
206Package: e2fsprogs-udeb
207Package-Type: udeb
208Section: debian-installer
209Priority: optional
210Depends: ${shlibs:Depends}, ${misc:Depends}
211Architecture: any
212Description: stripped-down versions of e2fsprogs, for debian-installer
213 This package is an e2fsprogs package built for a reduced size, so that
214 it can help to save space in debian-installer.
215 .
216 Don'''``t attempt to install this package, it has no support for a couple of
217 features you surely want.  Anyway it should refuse to install.
218'')dnl
219
220Package: e2fslibs
221Section: libs
222Depends: ${shlibs:Depends}, ${misc:Depends}
223Replaces: e2fsprogs (<< 1.34-1)
224Provides: libext2fs2, libe2p2
225Architecture: any
226MULTIARCH_HEADERS
227Description: ext2/ext3/ext4 file system libraries
228 The ext2, ext3 and ext4 file systems are successors of the original ext
229 ("extended") file system. They are the main file system types used for
230 hard disks on Debian and other Linux systems.
231 .
232 This package provides the ext2fs and e2p libraries, for userspace software
233 that directly accesses extended file systems. Programs that use libext2fs
234 include e2fsck, mke2fs, and tune2fs. Programs that use libe2p include
235 dumpe2fs, chattr, and lsattr.
236
237Package: e2fslibs-dev
238Section: libdevel
239Priority: extra
240Depends: libc6-dev | libc-dev, comerr-dev, e2fslibs (= ${binary:Version}), ${misc:Depends}
241Suggests: doc-base
242Provides: ext2fs-dev, e2p-dev
243Replaces: libkrb5-dev (<< 1.3)
244Architecture: any
245Description: ext2/ext3/ext4 file system libraries - headers and static libraries
246 The ext2, ext3 and ext4 file systems are successors of the original ext
247 ("extended") file system. They are the main file system types used for
248 hard disks on Debian and other Linux systems.
249 .
250 This package contains the development environment for the ext2fs and e2p
251 libraries.
252
253Package: e2fsprogs
254Essential: yes
255ifdef(`UTIL_LINUX_NG',
256``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}, util-linux (>= 2.15~rc1-1)
257'',
258``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
259'')dnl
260Multi-Arch: foreign
261Suggests: gpart, parted, fuse2fs, e2fsck-static
262Conflicts: dump (<< 0.4b4-4), quota (<< 1.55-8.1), initscripts (<< 2.85-4), sysvinit (<< 2.85-4)
263Replaces: hurd (<= 20040301-1), libblkid1 (<< 1.38+1.39-WIP-2005.12.10-2), libuuid1 (<< 1.38+1.39-WIP-2005.12.10-2)
264Architecture: any
265Description: ext2/ext3/ext4 file system utilities
266 The ext2, ext3 and ext4 file systems are successors of the original ext
267 ("extended") file system. They are the main file system types used for
268 hard disks on Debian and other Linux systems.
269 .
270 This package contains programs for creating, checking, and maintaining
271 ext2/3/4-based file systems.  It also includes the "badblocks" program,
272 which can be used to scan for bad blocks on a disk or other storage device.
273ifdef(`USE_DBGSYM',,``
274Package: e2fsprogs-dbg
275Section: debug
276Priority: extra
277Depends: e2fsprogs (= ${binary:Version}), ${misc:Depends}
278Architecture: any
279Description: debugging information for e2fsprogs
280 This package includes the debug information useful for debugging e2fsprogs
281 and its libraries, contained in the e2fsprogs and e2fsck-static packages.
282 The debug information is used for execution tracing and core
283 dump analysis.
284'')
285ifdef(`USE_DBGSYM',,ifdef(`UTIL_LINUX_NG',,``
286Package: uuid-runtime-dbg
287Section: debug
288Priority: extra
289Depends: uuid-runtime (= ${binary:Version}), ${misc:Depends}
290Architecture: any
291Description: debugging information for uuid-runtime
292 This package includes the debug information useful for debugging the
293 uuid runtime programs, contained in the uuid-runtime package.
294 The debugging information is used for execution tracing and core
295 dump analysis.
296''))dnl
297ifdef(`USE_DBGSYM',,``
298Package: e2fslibs-dbg
299Section: debug
300Priority: extra
301Depends: e2fslibs (= ${binary:Version}), ${misc:Depends}
302Architecture: any
303Description: debugging information for e2fslibs
304 This package includes the debug information useful for debugging the
305 ext2fs and e2p libraries, contained in the e2fslibs package.  The debug
306 information is used for execution tracing and core dump analysis.
307
308Package: libcomerr2-dbg
309Section: debug
310Priority: extra
311Depends: libcomerr2 (= ${binary:Version}), ${misc:Depends}
312Architecture: any
313Description: debugging information for libcomerr2
314 This package includes the debug information useful for debugging the
315 com_err library, contained in the libcomerr2 package.  The debugging
316 information is used for execution tracing and core dump analysis.
317
318Package: libss2-dbg
319Section: debug
320Priority: extra
321Depends: libss2 (= ${binary:Version}), ${misc:Depends}
322Architecture: any
323Description: debugging information for libss2
324 This package includes the debug information useful for debugging the
325 ss library, contained in the libss2 package.  The debug information
326 is used for execution tracing and core dump analysis.
327'')dnl
328ifdef(`USE_DBGSYM',,ifdef(`UTIL_LINUX_NG',,``
329Package: libblkid1-dbg
330Section: debug
331Priority: extra
332Depends: libblkid1 (= ${binary:Version}), ${misc:Depends}
333Architecture: any
334Description: debugging information for libblkid1
335 This package includes the debug information useful for debugging the
336 blkid library, contained in the libblkid1 package.  The debug
337 information is used for execution tracing and core dump analysis.
338
339Package: libuuid1-dbg
340Section: debug
341Priority: extra
342Depends: libuuid1 (= ${binary:Version}), ${misc:Depends}
343Architecture: any
344Description: debugging information for libuuid1
345 This package includes the debug information useful for debugging the
346 UUID library, contained in the libuuid1 package.  The debug
347 information is used for execution tracing and core dump analysis.
348''))dnl
349