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1# Burning<a name="EN-US_TOPIC_0000001170009518"></a>
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4## Mini and Small Systems<a name="section278314413530"></a>
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6### "Error: Opening COMxx: Access denied" Is Displayed After a Serial Port Is Selected for Burning<a name="section18988185615914"></a>
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8-   **Symptom**
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10    **Error: Opening COMxx: Access denied**  is displayed after clicking  **Burn**  and selecting a serial port.
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12    ![](figures/failed-to-open-the-serial-port.png)
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14-   **Possible Causes**
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16    The serial port has been used.
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18-   Solution
19
20    The serial port may be in use. Perform the following steps to troubleshoot:
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22    1.  Search for the serial port from the drop-down list in the  **TERMINAL**  panel.
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24        ![](figures/terminal-list.png)
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26    2.  Click the dustbin for the terminal using the serial port to disable the terminal.
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28
29### What should I do when the image failed to be burnt?<a name="section1370982513317"></a>
30
31-   **Symptom**
32
33    The burning status is not displayed after clicking  **Burn**  and selecting a serial port.
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35-   **Possible Causes**
36
37    The IDE is not restarted after the DevEco plug-in is installed.
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39-   **Solutions**
40
41    Restart the IDE.
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43
44### What should I do when no command output is displayed?<a name="section183421944953"></a>
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46-   **Symptom**
47
48    The serial port shows that the connection has been established. After the board is restarted, nothing is displayed when you press  **Enter**.
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50-   **Possible Cause 1**
51
52    The serial port is connected incorrectly.
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54-   **Solutions**
55
56    Change the serial port number.
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58    Start  **Device Manager**  to check whether the serial port connected to the board is the same as that connected to the terminal device. If the serial ports are different, perform step 1 in the  **Running an Image**  section to change the serial port number.
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60
61-   **Possible Cause 2**
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63    The U-Boot of the board is damaged.
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65-   **Solutions**
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67    Burn the U-Boot.
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69    If the fault persists after you perform the preceding operations, the U-Boot of the board may be damaged. You can burn the U-Boot by performing the following steps:
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71
721.  Obtain the U-Boot file.
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74    >![](../public_sys-resources/icon-notice.gif) **NOTICE:**
75    >The U-Boot file of the two boards can be obtained from the following paths, respectively.
76    >Hi3516D V300:  **device\\hisilicon\\hispark\_taurus\\sdk\_liteos\\uboot\\out\\boot\\u-boot-hi3516dv300.bin**
77    >Hi3518E V300:  **device\\hisilicon\\hispark\_aries\\sdk\_liteos\\uboot\\out\\boot\\u-boot-hi3518ev300.bin**
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792.  Burn the U-Boot file by following the procedures for burning a U-Boot file over USB.
80
81    Select the U-Boot files of corresponding development boards for burning by referring to  [Programming Flash Memory on the Hi3516](../quick-start/quickstart-lite-steps-hi3516-running.md)/[Programming Flash Memory on the Hi3518](../quick-start/quickstart-ide-lite-steps-hi3516-burn.md)
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833.  Log in to the serial port after the burning is complete.
84
85    **Figure  1**  Serial port displayed after the U-Boot is burnt<a name="en-us_topic_0000001128470856_en-us_topic_0000001053466255_fig155914681910"></a>
86    ![](figures/serial-port-displayed-after-the-u-boot-is-burnt.png "serial-port-displayed-after-the-u-boot-is-burnt")
87
88
89### What should I do when Windows-based PC failed to be connected to the board?<a name="section1215410450215"></a>
90
91-   **Symptom**
92
93    The file image cannot be obtained after clicking  **Burn**  and selecting a serial port.
94
95    **Figure  2**  Failed to obtain the image file due to unavailable connection<a name="en-us_topic_0000001128470856_fig135261439195819"></a>
96    ![](figures/failed-to-obtain-the-image-file-due-to-unavailable-connection.png "failed-to-obtain-the-image-file-due-to-unavailable-connection")
97
98-   **Possible Causes**
99
100    The board is disconnected from the Windows-based PC.
101
102    Windows Firewall does not allow Visual Studio Code to access the network.
103
104-   **Solutions**
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1061.  Check whether the network cable is properly connected.
1072.  Click  **Windows Firewall**.
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109    ![](figures/hi3516-network-and-firewall-setting.png)
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1113.  Click  **Firewall & network protection**, and on the displayed page, click  **Allow applications to communicate through Windows Firewall**.
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113    ![](figures/hi3516-firewall-and-network-protection.png)
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1154.  Select the Visual Studio Code application.
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117    ![](figures/hi3516-selecting-the-visual-studio-code-application.png)
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1195.  Select the  **Private**  and  **Public**  network access rights for the Visual Studio Code application.
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121    ![](figures/hi3516-allowing-the-visual-studio-code-application-to-access-the-network.png)
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