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1# Burning
2
3
4## Mini and Small Systems
5
6
7### "Error: Opening COMxx: Access denied" Is Displayed When I Start Burning
8
9- **Symptom**
10
11  After I click **Burn** and select a serial port, **Error: Opening COMxx: Access denied** is displayed.
12
13  **Figure 1** Access denied error
14
15  ![failed-to-open-the-serial-port](figures/failed-to-open-the-serial-port.png)
16
17- **Possible Causes**
18
19  The serial port is in use.
20
21- **Solution**
22
23  1. Search for the terminal using serial-xx from the drop-down list in the **TERMINAL** panel.
24
25     **Figure 2** Checking whether the serial port is in use
26
27     ![en-us_image_0000001243481989](figures/en-us_image_0000001243481989.png)
28
29  2. Click the dustbin icon as shown below to disable the terminal using the serial port.
30
31     **Figure 3** Disabling the terminal using the serial port
32
33     ![en-us_image_0000001243082093](figures/en-us_image_0000001243082093.png)
34
35  3. Click **Burn**, select the serial port, and start burning images again.
36
37     **Figure 4** Restarting the burning task
38
39     ![en-us_image_0000001198322224](figures/en-us_image_0000001198322224.png)
40
41
42### The Image Failed To Be Burnt
43
44- **Symptom**
45
46  The image failed to be burnt over a serial port.
47
48- **Possible Causes**
49
50  The DevEco Device Tool plug-in is not restarted after being installed.
51
52- **Solution**
53
54  Restart DevEco Device Tool.
55
56
57### No Command Output Is Displayed
58
59- **Symptom**
60
61  The serial port shows that the connection has been established. After the board is restarted, nothing is displayed when I press **Enter**.
62
63- **Possible Cause 1**
64
65  The serial port is connected incorrectly.
66
67- **Solution**
68
69  Change the serial port number.
70
71  Start **Device Manager** to check whether the serial port connected to the board is the same as that connected to the terminal device. If the serial ports are different, perform step 1 in the **Running an Image** section to change the serial port number.
72
73- **Possible Cause 2**
74
75  The U-Boot of the board is damaged.
76
77- **Solution**
78
79  Burn the U-Boot.
80
81  If the fault persists after you perform the preceding operations, the U-Boot of the board may be damaged. In this case, burn the U-Boot by performing the following steps:
82
83   1. Obtain the U-Boot file.
84      > ![icon-notice.gif](public_sys-resources/icon-notice.gif) **NOTICE**
85      > The U-Boot file of the two boards can be obtained from the following paths, respectively.
86      >
87      > Hi3516D V300: **device\hisilicon\hispark_taurus\sdk_liteos\uboot\out\boot\u-boot-hi3516dv300.bin**
88      >
89      > Hi3518E V300: **device\hisilicon\hispark_aries\sdk_liteos\uboot\out\boot\u-boot-hi3518ev300.bin**
90
91  2. Burn the U-Boot file.
92
93     Select the U-Boot files of the corresponding development board for burning. For details, see [Burning an Image](../quick-start/quickstart-ide-3516-burn.md).
94
95  3. Log in to the serial port after the burning is complete.
96
97     **Figure 5** Information displayed through the serial port after the U-Boot file is burnt
98
99     ![en-us_image_0000001243484907](figures/en-us_image_0000001243484907.png)
100
101
102### Windows-based PC Failed to Be Connected to the Board
103
104- **Symptom**
105
106  The file image cannot be obtained after clicking **Burn** and selecting a serial port.
107
108  **Figure 6** Failed to obtain the file image due to network disconnection
109
110  ![en-us_image_0000001198322428](figures/en-us_image_0000001198322428.png)
111
112- **Possible Causes**
113
114  The board is disconnected from the Windows-based PC.
115
116  Windows Firewall does not allow Visual Studio Code to access the network.
117
118- **Solution**
119
120  1. Make sure the network cable is properly connected.
121
122  2. Click **Windows Firewall**.
123
124     **Figure 7** Setting the firewall
125
126     ![en-us_image_0000001198162584](figures/en-us_image_0000001198162584.png)
127
128  3. Click **Firewall & network protection**. On the displayed page, click **Allow an app through the firewall**.
129
130     **Figure 8** Firewall & network protection
131
132     ![en-us_image_0000001198323146](figures/en-us_image_0000001198323146.png)
133
134  4. Select Visual Studio Code.
135
136     **Figure 9** Selecting Visual Studio Code
137
138     ![en-us_image_0000001198003232](figures/en-us_image_0000001198003232.png)
139
140  5. Select the **Private** and **Public** network access rights for Visual Studio Code.
141
142     **Figure 10** Allowing Visual Studio Code to access the network
143
144     ![en-us_image_0000001243084579](figures/en-us_image_0000001243084579.png)
145
146### The Development Board Failed to Be Identified by the Burning Tool
147
148- **Symptom**
149
150  During image burning, the burning tool displays a message indicating that no device is found.
151
152- **Possible Causes**
153
154  The cable between the Windows computer and the development board is not connected. (The cable required varies. In this example, the USB cable is used.)
155
156  The driver corresponding to the cable between the Windows computer and the development board is not installed.
157
158- **Solution**
159
160  1. Make sure the cable between the Windows computer and the development board is connected.
161
162  2. Open Device Manager in Windows.
163
164  3. Open the Universal Serial Bus controllers list.
165
166  4. Check whether the USB device driver has been installed. If an alarm is displayed, the driver has not been installed.
167
168  5. Depending on the Windows environment, install the desired USB device driver, such as FT23R USB UART Driver. Then try again.
169
170  6. If any other issue occurs, consult the relevant FAQ entry.
171
172