• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1# Copyright (c) 2023 Huawei Device Co., Ltd.
2# Licensed under the Apache License, Version 2.0 (the "License");
3# you may not use this file except in compliance with the License.
4# You may obtain a copy of the License at
5#
6#     http://www.apache.org/licenses/LICENSE-2.0
7#
8# Unless required by applicable law or agreed to in writing, software
9# distributed under the License is distributed on an "AS IS" BASIS,
10# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
11# See the License for the specific language governing permissions and
12# limitations under the License.
13
14%global cups_serverbin %{_exec_prefix}/lib/cups
15
16Name:    cups
17Epoch:   1
18Version: 2.4.0
19Release: 8
20Summary: CUPS is the standards-based, open source printing system for linux operating systems.
21License: GPLv2+ and LGPLv2+ with exceptions and AML
22Url:     https://openprinting.github.io/cups/
23# Apple stopped uploading the new versions into github, use OpenPrinting fork
24Source0: https://github.com/OpenPrinting/cups/releases/download/v%{version}/cups-%{version}-source.tar.gz
25
26Source1: cupsprinter.png
27Source2: macros.cups
28
29Patch1:  cups-system-auth.patch
30Patch2:  cups-multilib.patch
31Patch3:  cups-banners.patch
32Patch4:  cups-direct-usb.patch
33Patch5:  cups-driverd-timeout.patch
34Patch6:  cups-usb-paperout.patch
35Patch7:  cups-uri-compat.patch
36Patch8:  cups-freebind.patch
37Patch9:  cups-ipp-multifile.patch
38Patch10: cups-web-devices-timeout.patch
39
40Patch6000: backport-CVE-2022-26691.patch
41Patch6001: backport-Remove-legacy-code-for-RIP_MAX_CACHE-environment-variable.patch
42Patch6002: backport-Also-fix-cupsfilter.patch
43Patch6003: backport-CVE-2023-32324.patch
44Patch6004: fix-httpAddrGetList-test-case-fail.patch
45Patch6005: backport-CVE-2023-34241.patch
46
47BuildRequires: pam-devel pkgconf-pkg-config pkgconfig(gnutls) libacl-devel openldap-devel pkgconfig(libusb-1.0)
48BuildRequires: krb5-devel pkgconfig(avahi-client) systemd pkgconfig(libsystemd) pkgconfig(dbus-1) python3-cups
49BuildRequires: automake zlib-devel gcc gcc-c++ libselinux-devel audit-libs-devel make
50Requires: dbus systemd acl cups-filters /usr/sbin/alternatives
51Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
52Requires: %{name}-client%{?_isa} = %{epoch}:%{version}-%{release}
53Requires: %{name}-filesystem = %{epoch}:%{version}-%{release}
54
55# Requires working PrivateTmp (bug #807672)
56Requires(pre): systemd
57Requires(post): systemd
58Requires(post): grep, sed
59Requires(preun): systemd
60Requires(postun): systemd
61
62%description
63CUPS is the standards-based, open source printing system developed by Apple Inc.
64for UNIX®-like operating systems. CUPS uses the Internet Printing
65Protocol (IPP) to support printing to local and network printers.
66
67%package client
68Summary: CUPS printing system - client programs
69License: GPLv2
70Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
71Provides: /usr/bin/lpq /usr/bin/lpr /usr/bin/lp /usr/bin/cancel /usr/bin/lprm /usr/bin/lpstat
72Requires: /usr/sbin/alternatives
73Provides: lpr
74
75%description client
76CUPS printing system provides a portable printing layer for
77UNIX® operating systems. This package contains command-line client
78programs.
79
80%package devel
81Summary: CUPS printing system - development environment
82License: LGPLv2
83Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
84Requires: gnutls-devel krb5-devel zlib-devel
85
86%description devel
87CUPS is the standards-based, open source printing system developed by Apple Inc.
88for macOS® and other UNIX®-like operating systems. Developers can use this development
89package to develop other printer drivers.
90
91%package libs
92Summary: CUPS libs
93License: LGPLv2 and zlib
94
95%description libs
96CUPS printing system provides a portable printing layer for
97UNIX® operating systems. It has been developed by Apple Inc.
98to promote a standard printing solution for all UNIX vendors and users.
99CUPS provides the System V and Berkeley command-line interfaces.
100The cups-libs package provides libraries used by applications to use CUPS
101natively, without needing the lp/lpr commands.
102
103%package filesystem
104Summary: CUPS printing system - directory layout
105BuildArch: noarch
106
107%description filesystem
108CUPS printing system provides a portable printing layer for
109UNIX® operating systems. This package provides some directories which are
110required by other packages that add CUPS drivers (i.e. filters, backends etc.).
111
112%package lpd
113Summary: CUPS printing system - lpd emulation
114Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
115Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
116Provides: lpd
117
118%description lpd
119CUPS printing system provides a portable printing layer for
120UNIX® operating systems. This is the package that provides standard
121lpd emulation.
122
123%package ipptool
124Summary: CUPS printing system - tool for performing IPP requests
125Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
126Requires: avahi
127
128%description ipptool
129Sends IPP requests to the specified URI and tests and/or displays the results.
130
131%package printerapp
132Summary: CUPS printing system - tools for printer application
133Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
134Requires: avahi
135
136%description printerapp
137Provides IPP everywhere printer application ippeveprinter and tools for printing
138PostScript and HP PCL document formats - ippevepcl and ippeveps. The printer
139application enables older printers for IPP everywhere standard - so if older printer
140is installed with a printer application, its print queue acts as IPP everywhere printer
141to CUPS daemon. This solution will substitute printer drivers and raw queues in the future.
142
143%package    help
144Summary:    Documents for cups
145Buildarch:  noarch
146
147%description    help
148Man pages and other related documents.
149
150%prep
151%autosetup -n %{name}-%{version} -p1
152
153sed -i -e '1iMaxLogSize 0' conf/cupsd.conf.in
154sed -i -e 's,^ErrorLog .*$,ErrorLog syslog,' -i -e 's,^AccessLog .*$,AccessLog syslog,' -i -e 's,^PageLog .*,PageLog syslog,' conf/cups-files.conf.in
155perl -pi -e "s,^.SILENT:,," Makedefs.in
156
157aclocal -I config-scripts
158autoconf -f -I config-scripts
159
160%build
161export DSOFLAGS="$DSOFLAGS -L../cgi-bin -L../filter -L../ppdc -L../scheduler -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/generic-hardened-ld -Wl,-z,relro,-z,now -fPIE -pie"
162export CFLAGS="$RPM_OPT_FLAGS -fstack-protector-all -DLDAP_DEPRECATED=1"
163# --enable-debug to avoid stripping binaries
164%configure --with-docdir=%{_datadir}/%{name}/www --enable-debug \
165    --enable-lspp \
166    --with-exe-file-perm=0755 \
167    --with-cupsd-file-perm=0755 \
168    --with-log-file-perm=0600 \
169    --enable-relro \
170    --with-dbusdir=%{_sysconfdir}/dbus-1 \
171    --enable-avahi \
172    --enable-threads \
173    --enable-gnutls \
174    --enable-webif \
175    --with-xinetd=no \
176    --with-access-log-level=actions \
177    --enable-page-logging \
178    --with-rundir=%{_rundir}/cups \
179    --enable-sync-on-close \
180    localedir=%{_datadir}/locale
181
182%make_build
183
184%check
185make check
186
187%install
188make BUILDROOT=${RPM_BUILD_ROOT} install
189
190rm -rf  ${RPM_BUILD_ROOT}%{_initddir} ${RPM_BUILD_ROOT}%{_sysconfdir}/{init.d,rc?.d}
191install -d ${RPM_BUILD_ROOT}%{_unitdir}
192
193find ${RPM_BUILD_ROOT}%{_datadir}/cups/model -name "*.ppd" |xargs gzip -n9f
194
195pushd ${RPM_BUILD_ROOT}%{_bindir}
196for file in cancel lp lpq lpr lprm lpstat; do
197    mv $file $file.cups
198done
199
200mv ${RPM_BUILD_ROOT}%{_sbindir}/lpc ${RPM_BUILD_ROOT}%{_sbindir}/lpc.cups
201cd ${RPM_BUILD_ROOT}%{_mandir}/man1
202for file in cancel lp lpq lpr lprm lpstat; do
203    mv $file.1 $file-cups.1
204done
205
206mv ${RPM_BUILD_ROOT}%{_mandir}/man8/lpc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/lpc-cups.8
207popd
208
209install -d ${RPM_BUILD_ROOT}%{_datadir}/pixmaps ${RPM_BUILD_ROOT}%{_sysconfdir}/X11/sysconfig \
210           ${RPM_BUILD_ROOT}%{_sysconfdir}/X11/applnk/System \
211           ${RPM_BUILD_ROOT}%{_rpmconfigdir}/macros.d
212install -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/pixmaps
213install -m 0644 %{SOURCE2} ${RPM_BUILD_ROOT}%{_rpmconfigdir}/macros.d
214
215touch ${RPM_BUILD_ROOT}%{_sysconfdir}/cups/{printers,classes,client,subscriptions}.conf
216touch ${RPM_BUILD_ROOT}%{_sysconfdir}/cups/lpoptions
217
218install -d ${RPM_BUILD_ROOT}%{_datadir}/ppd
219
220# Remove unshipped files.
221rm -rf %{buildroot}%{_mandir}/cat? %{buildroot}%{_mandir}/*/cat?
222rm -f %{buildroot}%{_datadir}/applications/cups.desktop
223rm -rf %{buildroot}%{_datadir}/icons
224# there are pdf-banners shipped with cups-filters (#919489)
225rm -rf %{buildroot}%{_datadir}/cups/banners
226rm -f %{buildroot}%{_datadir}/cups/data/testprint
227
228install -d ${RPM_BUILD_ROOT}%{_tmpfilesdir}
229cat > ${RPM_BUILD_ROOT}%{_tmpfilesdir}/cups.conf <<EOF
230d /run/cups 0755 root lp -
231d /run/cups/certs 0511 lp sys -
232d /var/spool/cups/tmp - - - 30d
233EOF
234
235cat > ${RPM_BUILD_ROOT}%{_tmpfilesdir}/cups-lp.conf <<EOF
236c /dev/lp0 0660 root lp - 6:0
237c /dev/lp1 0660 root lp - 6:1
238c /dev/lp2 0660 root lp - 6:2
239c /dev/lp3 0660 root lp - 6:3
240EOF
241
242find ${RPM_BUILD_ROOT} -type f -o -type l | sed '
243s:.*\('%{_datadir}'/\)\([^/_]\+\)\(.*\.po$\):%lang(\2) \1\2\3:
244/^%lang(C)/d
245/^\([^%].*\)/d
246' > %{name}.lang
247
248%post
249%systemd_post %{name}.path %{name}.socket %{name}.service
250
251install -d ${RPM_BUILD_ROOT}%{_localstatedir}/run/cups/certs
252
253/bin/sed -i -e "s,^PageLogFormat,#PageLogFormat,i" %{_sysconfdir}/cups/cups-files.conf
254
255%post client
256/usr/sbin/alternatives --install %{_bindir}/lpr print %{_bindir}/lpr.cups 40 \
257	 --slave %{_bindir}/lp print-lp %{_bindir}/lp.cups \
258	 --slave %{_bindir}/lpq print-lpq %{_bindir}/lpq.cups \
259	 --slave %{_bindir}/lprm print-lprm %{_bindir}/lprm.cups \
260	 --slave %{_bindir}/lpstat print-lpstat %{_bindir}/lpstat.cups \
261	 --slave %{_bindir}/cancel print-cancel %{_bindir}/cancel.cups \
262	 --slave %{_sbindir}/lpc print-lpc %{_sbindir}/lpc.cups \
263	 --slave %{_mandir}/man1/cancel.1.gz print-cancelman %{_mandir}/man1/cancel-cups.1.gz \
264	 --slave %{_mandir}/man1/lp.1.gz print-lpman %{_mandir}/man1/lp-cups.1.gz \
265	 --slave %{_mandir}/man8/lpc.8.gz print-lpcman %{_mandir}/man8/lpc-cups.8.gz \
266	 --slave %{_mandir}/man1/lpq.1.gz print-lpqman %{_mandir}/man1/lpq-cups.1.gz \
267	 --slave %{_mandir}/man1/lpr.1.gz print-lprman %{_mandir}/man1/lpr-cups.1.gz \
268	 --slave %{_mandir}/man1/lprm.1.gz print-lprmman %{_mandir}/man1/lprm-cups.1.gz \
269	 --slave %{_mandir}/man1/lpstat.1.gz print-lpstatman %{_mandir}/man1/lpstat-cups.1.gz || :
270
271%post lpd
272%systemd_post cups-lpd.socket
273
274%ldconfig_scriptlets libs
275
276%preun
277%systemd_preun %{name}.path %{name}.socket %{name}.service
278
279%preun client
280if [ $1 -eq 0 ] ; then
281	/usr/sbin/alternatives --remove print %{_bindir}/lpr.cups || :
282fi
283
284%preun lpd
285%systemd_preun cups-lpd.socket
286
287%postun
288%systemd_postun_with_restart %{name}.path %{name}.socket %{name}.service
289
290%postun lpd
291%systemd_postun_with_restart cups-lpd.socket
292
293%triggerin -- samba-client
294ln -sf %{_libexecdir}/samba/cups_backend_smb %{_exec_prefix}/lib/cups/backend/smb || :
295exit 0
296
297%triggerun -- samba-client
298[ $2 = 0 ] || exit 0
299rm -f %{_exec_prefix}/lib/cups/backend/smb
300
301%files -f %{name}.lang
302%{_bindir}/cupstestppd
303%{_bindir}/ppd*
304%{_sbindir}/*
305# client subpackage
306%exclude %{_sbindir}/lpc.cups
307%dir %{cups_serverbin}/daemon
308%{cups_serverbin}/daemon/cups-deviced
309%{cups_serverbin}/daemon/cups-driverd
310%{cups_serverbin}/daemon/cups-exec
311%{cups_serverbin}/backend/*
312%{cups_serverbin}/cgi-bin
313%{cups_serverbin}/filter/*
314%{cups_serverbin}/monitor
315%{cups_serverbin}/notifier
316%{_datadir}/cups/drv/sample.drv
317%{_datadir}/cups/examples
318%{_datadir}/cups/mime/mime.types
319%{_datadir}/cups/mime/mime.convs
320%{_datadir}/cups/ppdc/*.defs
321%{_datadir}/cups/ppdc/*.h
322%dir %{_datadir}/cups/templates
323%{_datadir}/cups/templates/*.tmpl
324%dir %{_datadir}/cups/templates/de
325%{_datadir}/cups/templates/de/*.tmpl
326%dir %{_datadir}/cups/templates/da
327%{_datadir}/cups/templates/da/*.tmpl
328%dir %{_datadir}/cups/templates/es
329%{_datadir}/cups/templates/es/*.tmpl
330%dir %{_datadir}/cups/templates/fr
331%{_datadir}/cups/templates/fr/*.tmpl
332%dir %{_datadir}/cups/templates/ja
333%{_datadir}/cups/templates/ja/*.tmpl
334%dir %{_datadir}/cups/templates/pt_BR
335%{_datadir}/cups/templates/pt_BR/*.tmpl
336%dir %{_datadir}/cups/templates/ru
337%{_datadir}/cups/templates/ru/*.tmpl
338%dir %{_datadir}/%{name}/usb
339%{_datadir}/%{name}/usb/org.cups.usb-quirks
340%dir %{_datadir}/%{name}/www
341%{_datadir}/%{name}/www/images
342%{_datadir}/%{name}/www/*.css
343%dir %{_datadir}/%{name}/www/de
344%dir %{_datadir}/%{name}/www/da
345%dir %{_datadir}/%{name}/www/es
346%dir %{_datadir}/%{name}/www/fr
347%dir %{_datadir}/%{name}/www/ja
348%dir %{_datadir}/%{name}/www/pt_BR
349%dir %{_datadir}/%{name}/www/ru
350%{_datadir}/pixmaps/cupsprinter.png
351%dir %attr(1770,root,lp) %{_localstatedir}/spool/cups/tmp
352%dir %attr(0710,root,lp) %{_localstatedir}/spool/cups
353%dir %attr(0755,root,lp) %{_localstatedir}/log/cups
354# client subpackage
355%exclude %{_mandir}/man1/lp*.1.gz
356%exclude %{_mandir}/man1/cancel-cups.1.gz
357%exclude %{_mandir}/man8/lpc-cups.8.gz
358# devel subpackage
359%exclude %{_mandir}/man1/cups-config.1.gz
360# ipptool subpackage
361%exclude %{_mandir}/man1/ipptool.1.gz
362%exclude %{_mandir}/man5/ipptoolfile.5.gz
363# lpd subpackage
364%exclude %{_mandir}/man8/cups-lpd.8.gz
365# printerapp
366%exclude %{_mandir}/man1/ippeveprinter.1.gz
367%exclude %{_mandir}/man7/ippevepcl.7.gz
368%exclude %{_mandir}/man7/ippeveps.7.gz
369%dir %attr(0755,root,lp) %{_rundir}/cups
370%dir %attr(0511,lp,sys) %{_rundir}/cups/certs
371%dir %attr(0755,root,lp) %{_sysconfdir}/cups
372%attr(0640,root,lp) %{_sysconfdir}/cups/cupsd.conf.default
373%verify(not md5 size mtime) %config(noreplace) %attr(0640,root,lp) %{_sysconfdir}/cups/cupsd.conf
374%verify(not md5 size mtime) %config(noreplace) %attr(0640,root,lp) %{_sysconfdir}/cups/cups-files.conf
375%attr(0640,root,lp) %{_sysconfdir}/cups/cups-files.conf.default
376%verify(not md5 size mtime) %config(noreplace) %attr(0644,root,lp) %{_sysconfdir}/cups/client.conf
377%verify(not md5 size mtime) %config(noreplace) %attr(0600,root,lp) %{_sysconfdir}/cups/classes.conf
378%verify(not md5 size mtime) %config(noreplace) %attr(0600,root,lp) %{_sysconfdir}/cups/printers.conf
379%verify(not md5 size mtime) %config(noreplace) %attr(0644,root,lp) %{_sysconfdir}/cups/snmp.conf
380%attr(0640,root,lp) %{_sysconfdir}/cups/snmp.conf.default
381%verify(not md5 size mtime) %config(noreplace) %attr(0640,root,lp) %{_sysconfdir}/cups/subscriptions.conf
382%verify(not md5 size mtime) %config(noreplace) %attr(0644,root,lp) %{_sysconfdir}/cups/lpoptions
383%dir %attr(0755,root,lp) %{_sysconfdir}/cups/ppd
384%dir %attr(0700,root,lp) %{_sysconfdir}/cups/ssl
385%config(noreplace) %{_sysconfdir}/dbus-1/system.d/cups.conf
386%config(noreplace) %{_sysconfdir}/pam.d/cups
387%{_tmpfilesdir}/cups.conf
388%{_tmpfilesdir}/cups-lp.conf
389%attr(0644, root, root)%{_unitdir}/%{name}.service
390%attr(0644, root, root)%{_unitdir}/%{name}.socket
391%attr(0644, root, root)%{_unitdir}/%{name}.path
392
393%files client
394%{_bindir}/cancel*
395%{_bindir}/lp*
396%{_sbindir}/lpc.cups
397%{_mandir}/man1/cancel-cups.1.gz
398%{_mandir}/man1/lp*.1.gz
399%{_mandir}/man8/lpc-cups.8.gz
400
401%files libs
402%{license} LICENSE
403%{license} NOTICE
404%{_libdir}/libcups.so.2
405%{_libdir}/libcupsimage.so.2
406
407%files filesystem
408%dir %{cups_serverbin}
409%dir %{cups_serverbin}/backend
410%dir %{cups_serverbin}/driver
411%dir %{cups_serverbin}/filter
412%dir %{_datadir}/cups
413%dir %{_datadir}/cups/data
414%dir %{_datadir}/cups/drv
415%dir %{_datadir}/cups/mime
416%dir %{_datadir}/cups/model
417%dir %{_datadir}/cups/ppdc
418%dir %{_datadir}/ppd
419
420%files devel
421%{_bindir}/cups-config
422%{_includedir}/cups
423%{_libdir}/*.so
424%{_rpmconfigdir}/macros.d/macros.cups
425%{_prefix}/lib/pkgconfig/cups.pc
426
427%files lpd
428%{cups_serverbin}/daemon/cups-lpd
429%{_mandir}/man8/cups-lpd.8.gz
430%attr(0644, root, root)%{_unitdir}/cups-lpd.socket
431%attr(0644, root, root)%{_unitdir}/cups-lpd@.service
432
433%files ipptool
434%{_bindir}/ippfind
435%{_bindir}/ipptool
436%dir %{_datadir}/cups/ipptool
437%{_datadir}/cups/ipptool/*
438%{_mandir}/man1/ipptool.1.gz
439%{_mandir}/man5/ipptoolfile.5.gz
440
441%files printerapp
442%{_bindir}/ippeveprinter
443%dir %{cups_serverbin}/command
444%{cups_serverbin}/command/ippevepcl
445%{cups_serverbin}/command/ippeveps
446%{_mandir}/man1/ippeveprinter.1.gz
447%{_mandir}/man7/ippevepcl.7.gz
448%{_mandir}/man7/ippeveps.7.gz
449
450%files help
451%{_mandir}/man[1578]/*
452%{_mandir}/man1/cups-config.1.gz
453%doc README.md CREDITS.md CHANGES.md
454%doc %{_datadir}/%{name}/www/index.html
455%doc %{_datadir}/%{name}/www/help
456%doc %{_datadir}/%{name}/www/robots.txt
457%doc %{_datadir}/%{name}/www/de/index.html
458%doc %{_datadir}/%{name}/www/da/index.html
459%doc %{_datadir}/%{name}/www/es/index.html
460%doc %{_datadir}/%{name}/www/fr/index.html
461%doc %{_datadir}/%{name}/www/ja/index.html
462%doc %{_datadir}/%{name}/www/ru/index.html
463%doc %{_datadir}/%{name}/www/pt_BR/index.html
464%doc %{_datadir}/%{name}/www/apple-touch-icon.png
465
466%changelog
467* Mon Jun 26 2023 zhouwenpei <zhouwenpei@h-partners.com> - 1:2.4.0-8
468- fix CVE-2023-34241
469
470* Fri Jun 9 2023 zhangpan <zhangpan103@h-partners.com> - 1:2.4.0-7
471- fix build error
472
473* Sat Jun 3 2023 zhouwenpei <zhouwenpei@h-partners.com> - 1:2.4.0-6
474- fix CVE-2023-32324
475
476* Tue Feb 21 2023 zhouwenpei <zhouwenpei@h-partners.com> - 2.4.0-5
477- fix update conflict of devel and help
478
479* Wed Jun 15 2022 hanhui <hanhui15@h-partners.com> - 2.4.0-4
480- Remove legacy code for RIP_MAX_CACHE environment variable
481
482* Thu Jun 9 2022 hanhui <hanhui15@h-partners.com> - 2.4.0-3
483- fix CVE-2022-26691
484
485* Thu May 12 2022 zhanzhimin <zhanzhimin@h-partners.com> - 2.4.0-2
486- fix official website address
487
488* Thu Dec 9 2021 hanhui <hanhui15@huawei.com> - 2.4.0-1
489- DESC:update to cups-2.4.0
490
491* Thu Nov 04 2021 wangkerong <wangkerong@huawei.com> - 2.3.3-8
492- Type:bugfix
493- ID:NA
494- SUG:NA
495- DESC:fix cups-devel requires error
496
497* Fri Sep 24 2021 liuyumeng <liuyumeng5@huawei.com> - 2.3.3-7
498- Type:CVE
499- ID:CVE-2020-10001
500- SUG:NA
501- DESC:Fix CVE-2020-10001
502
503* Tue Jun 08 2021 wangkerong <wangkeorng@huawei.com> - 2.3.3-6
504- Type:CVE
505- ID:CVE-2021-25317
506- SUG:NA
507- DESC:Fix CVE-2021-25317
508
509* Tue May 25 2021 liuyumeng <liuyumeng@huawei.com> - 2.3.3-5
510- remove unused ncp backend
511
512* Mon May 24 2021 liuyumeng <liuyumeng@huawei.com> - 2.3.3-4
513- Type:bugfix
514- ID:NA
515- SUG:NA
516- DESC:Compilation optimization
517
518* Tue Sep 29 2020 hanhui <hanhui15@huawei.com> - 2.3.3-3
519- Type:bugfix
520- ID:NA
521- SUG:NA
522- DESC:fix build bug
523
524* Wed Sep 9 2020 hanhui <hanhui15@huawei.com> - 2.3.3-2
525- Type:bugfix
526- ID:NA
527- SUG:NA
528- DESC:modify source url
529
530* Mon Jul 20 2020 wangye <wang70@huawei.com> - 2.3.3-1
531- Type:enhancement
532- ID:NA
533- SUG:NA
534- DESC:upgrade to 2.3.3
535
536* Fri Jun 12 2020 hanhui <hanhui15@huawei.com> - 2.2.13-1
537- Type:enhancement
538- ID:NA
539- SUG:NA
540- DESC:upgrade to 2.2.13
541
542* Thu Mar 26 2020 gaihuiying <gaihuiying1@huawei.com> - 2.2.8-9
543- Type:cves
544- ID:CVE-2019-2228
545- SUG:restart
546- DESC:fix CVE-2019-2228
547
548* Sat Jan 11 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.2.8-8
549- Type:enhancement
550- ID:NA
551- SUG:NA
552- DESC: delete patches
553
554* Wed Sep 25 2019 gaoguanghui <gaoguanghui1@huawei.com> - 2.2.8-7
555- Type:cves
556- ID:CVE-2019-8675 CVE-2019-8696
557- SUG:restart
558- DESC:fix CVE-2019-8675 CVE-2019-8696
559
560* Wed Sep 18 2019 Guan Yanjie <guanyanjie@huawei.com> - 2.2.8-6
561- Package init
562