• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1Name:           re2
2Version:        20211101
3Release:        3
4Summary:        Provide backtracking RE engine
5License:        BSD
6URL:            http://github.com/google/re2/
7Source0:        https://github.com/google/re2/archive/2021-11-01.tar.gz
8Patch0:         backport-fix-64-to-32-bit-clang-conversion-warning.patch
9Patch1:         add-some-testcases-for-abnormal-branches.patch
10BuildRequires:  gcc-c++
11
12%description
13RE2 is a fast, safe, thread-friendly alternative to backtracking regular
14expression engines like those used in PCRE, Perl, and Python. It is a C++ library.
15
16%package        devel
17Summary:        Provide re2 symbolic links with C ++ header files and libraries
18Requires:       %{name} = %{version}-%{release}
19
20%description    devel
21This package contains C ++ header files and symbolic links to re2's shared libraries.
22If you want to develop programs using re2, you need to install re2-devel.
23
24%prep
25%autosetup -n %{name}-2021-11-01 -p1
26
27%build
28%make_build CXXFLAGS="${CXXFLAGS:-%optflags} -pthread -std=c++11" \
29            LDFLAGS="${LDFLAGS:-%__global_ldflags} -pthread" \
30            includedir=%{_includedir} libdir=%{_libdir}
31
32%install
33%make_install includedir=%{_includedir} libdir=%{_libdir}
34
35%check
36make %{?_smp_mflags} shared-test
37
38%post
39/sbin/ldconfig
40
41%postun
42/sbin/ldconfig
43
44%files
45%doc AUTHORS CONTRIBUTORS README LICENSE
46%{_libdir}/lib%{name}.so.*
47
48%files devel
49%{_includedir}/%{name}
50%{_libdir}/{lib%{name}.so,pkgconfig/%{name}.pc}
51%exclude %{_libdir}/libre2.a
52
53%changelog
54* Wed Dec 14 2022 zhouyihang <zhouyihang3@h-partners.com> - 20211101-3
55- add some testcases for abnormal branches
56
57* Mon Oct 24 2022 gaihuiying <eaglegai@163.com> - 20211101-2
58- fix 64 to 32 bit clang conversion warning
59
60* Thu Dec 16 2021 yanglu <yanglu72@huawei.com> - 20211101-1
61- upgrade to 20211101
62
63* Thu Dec 3 2020 Guoshuai Sun <sunguoshuai@huawei.com> - 20200801-1
64- upgrade to 20200801
65
66* Fri Nov 29 2019 fengbing <fengbing7@huawei.com> - 20160401-8
67- Package init
68