• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1#Resolve name conflict with libusb-compat-0.1
2%global source  libusb
3
4Name:           libusbx
5Version:        1.0.26
6Release:        1
7Summary:        Library for accessing USB devices
8License:        LGPLv2+
9URL:            http://libusb.info
10Source0:        https://github.com/libusb/libusb/releases/download/v1.0.26/libusb-1.0.26.tar.bz2
11
12BuildRequires:  systemd-devel doxygen libtool
13
14%description
15libusb is a library for USB device access from Linux, macOS, Windows, OpenBSD/NetBSD and Haiku userspace. It is written in C (Haiku backend in C++) and licensed under the GNU Lesser General Public License version 2.1 or, at your option, any later version (see COPYING).
16
17libusb is abstracted internally in such a way that it can hopefully be ported to other operating systems. Please see the PORTING file for more information.
18
19%package        devel
20Summary:        %{name} libs and docs files for development
21Requires:       %{name}%{?_isa} = %{version}-%{release}
22Provides:       libusb1-devel = %{version}-%{release}
23Provides:       libusb1-devel-doc = %{version}-%{release}
24Provides:       libusbx-devel-doc
25Obsoletes:      libusb1-devel <= 1.0.9
26Obsoletes:      libusb1-devel-doc <= 1.0.22-1
27Obsoletes:      libusbx-devel-doc
28
29%description    devel
30The %{name}-devel package contains libraries and header files.
31
32%prep
33%autosetup -n %{source}-%{version} -p1
34
35%build
36mkdir -p m4
37autoreconf -ivf
38%configure --disable-static --enable-examples-build
39%make_build
40make docs -C doc
41
42%check
43make check
44
45%install
46%make_install
47
48%ldconfig_scriptlets
49
50%files
51%doc AUTHORS README ChangeLog
52%license COPYING
53%{_libdir}/*.so.*
54%exclude %{_libdir}/*.la
55
56%files devel
57%doc examples/*.c
58%{_includedir}/libusb-1.0
59%{_libdir}/*.so
60%{_libdir}/pkgconfig/libusb-1.0.pc
61
62%changelog
63* Fri Oct 28 2022 Wenchao Hao <haowenchao@hauwei.com> - 1.0.26-1
64- Update to libusb-1.0.26
65
66* Tue Oct 11 2022 huangduirong <huangduirong@huawei.com> - 1.0.24-2
67- Type:bugfix
68- ID:NA
69- SUG:NA
70- DESC:Move autoreconf to build
71
72* Wed Nov 17 2021 Wenchao Hao <haowenchao@hauwei.com> - 1.0.24-1
73- Update to libusb-1.0.24
74
75* Fri Jul 23 2021 zhouwenpei <zhouwenpei1@hauwei.com> - 1.0.23-4
76- remove unnecessary build require.
77
78* Wed Nov 4 2020 lixiaokeng <lixiaokeng@hauwei.com> - 1.0.23-3
79- add make check
80
81* Mon Jul 27 2020 Zhiqiang Liu <lzhq28@mail.ustc.edu.cn> - 1.0.23-2
82- backport upstream patches.
83
84* Thu Jul 16 2020 zhangyouming <zhangyouming4@huawei.com> - 1.0.23-1
85- upgrade form 1.0.22 to 1.0.23
86
87* Wed Mar 25 2020 hy-euler <eulerstoragemt@huawei.com> - 1.0.22-3
88- delete -Sgit in %autosetup
89
90* Sat Aug 31 2019 suweifeng <suweifeng1@huawei.com> - 1.0.22-2
91- Package init
92