• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1Name:           e2fsprogs
2Version:        1.46.4
3Release:        17
4Summary:        Second extended file system management tools
5License:        GPLv2+ and LGPLv2 and MIT
6URL:            http://e2fsprogs.sourceforge.net/
7Source0:        https://www.kernel.org/pub/linux/kernel/people/tytso/%{name}/v%{version}/%{name}-%{version}.tar.xz
8Source1:        ext2_types-wrapper.h
9
10Patch1:		0001-e2fsprogs-set-hugefile-from-4T-to-1T-in-hugefile-tes.patch
11Patch2:		0002-libss-add-newer-libreadline.so.8-to-dlopen-path.patch
12Patch3:		0003-tests-update-expect-files-for-f_mmp_garbage.patch
13Patch4:		0004-tests-update-expect-files-for-f_large_dir-and-f_larg.patch
14Patch5:		0005-resize2fs-resize2fs-disk-hardlinks-will-be-error.patch
15Patch6:		0006-e2fsck-exit-journal-recovery-when-find-EIO-ENOMEM-er.patch
16Patch7:		0007-e2fsck-exit-journal-recovery-when-jounral-superblock.patch
17Patch8:		0008-e2fsck-add-env-param-E2FS_UNRELIABLE_IO-to-fi.patch
18Patch9:		0009-e2mmpstatus.8.in-detele-filesystem-can-be-UUID-or-LA.patch
19Patch10:	0010-tests-update-expect-file-for-u_direct_io.patch
20Patch11:	0011-libext2fs-don-t-old-the-CACHE_MTX-while-doing-I-O.patch
21Patch12:	0012-tests-fix-ACL-printing-tests.patch
22Patch13:	0013-e2fsck-do-not-clean-up-file-acl-if-the-inode-is-trun.patch
23Patch14:	0014-e2fsck-handle-level-is-overflow-in-ext2fs_extent_get.patch
24Patch15:	0015-libext2fs-add-sanity-check-to-extent-manipulation.patch
25Patch16:        0016-e2fsprogs-add-sw64.patch
26Patch17:	0017-tune2fs-do-not-change-j_tail_sequence-in-journal-sup.patch
27Patch18:	0018-debugfs-teach-logdump-the-n-num_trans-option.patch
28Patch19:	0019-tune2fs-fix-tune2fs-segfault-when-ext2fs_run_ext3_jo.patch
29Patch20:	0020-tune2fs-tune2fs_main-should-return-rc-when-some-erro.patch
30Patch21:	0021-tune2fs-exit-directly-when-fs-freed-in-ext2fs_run_ext3_journal.patch
31Patch22:	0022-unix_io.c-fix-deadlock-problem-in-unix_write_blk64.patch
32
33
34BuildRequires:  gcc pkgconfig texinfo
35BuildRequires:  fuse-devel libblkid-devel libuuid-devel
36BuildRequires:  audit
37Recommends:	%{name}-help = %{version}-%{release}
38
39Provides:       e2fsprogs-libs%{?_isa} e2fsprogs-libs
40Obsoletes:      e2fsprogs-libs
41Provides:       libcom_err%{?_isa} libcom_err
42Obsoletes:      libcom_err
43Provides:       libss%{?_isa} libss
44Obsoletes:      libss
45
46%description
47The e2fsprogs package consists of a lot of tools for users to create,
48check, modify, and correct any inconsistencies in second extended file
49system.
50
51%package devel
52Summary: Second extended file system libraries and headers
53License: GPLv2 and LGPLv2 and MIT
54Requires: e2fsprogs = %{version}-%{release}
55Requires: gawk
56Requires: pkgconfig
57Requires(post): info
58Requires(preun): info
59Provides: libcom_err-devel%{?_isa} libcom_err-devel
60Obsoletes: libcom_err-devel
61Provides: libss-devel%{?_isa} libss-devel
62Obsoletes: libss-devel
63Provides: e2fsprogs-static{?_isa} e2fsprogs-static
64Obsoletes: e2fsprogs-static
65
66%description devel
67This package provides libraries and header files to develop
68second extended file system userspace programs.
69
70%package help
71Summary: man files for e2fsprogs
72Requires: man
73BuildArch: noarch
74
75%description help
76This packages includes man files for e2fsprogs.
77
78%prep
79%autosetup -n %{name}-%{version} -p1
80
81
82%build
83%configure CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
84           --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
85           --disable-e2initrd-helper --disable-libblkid --disable-libuuid \
86           --enable-quota --with-root-prefix=/usr
87%make_build V=1
88
89%install
90make install install-libs DESTDIR=%{buildroot} INSTALL="%{__install} -p" \
91    root_sbindir=%{_sbindir} root_libdir=%{_libdir}
92chmod +w %{buildroot}%{_libdir}/*.a
93
94# Replace arch-dependent header file with arch-independent stub (when needed).
95#%multilib_fix_c_header --file %{_includedir}/ext2fs/ext2_types.h
96# ugly hack to allow parallel install of 32-bit and 64-bit -devel packages:
97%define multilib_arches %{ix86} x86_64
98
99%ifarch %{multilib_arches}
100mv -f %{buildroot}%{_includedir}/ext2fs/ext2_types.h \
101      %{buildroot}%{_includedir}/ext2fs/ext2_types-%{_arch}.h
102
103install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/ext2fs/ext2_types.h
104
105%endif
106
107%find_lang %{name}
108
109rm -f %{buildroot}/etc/cron.d/e2scrub_all
110rm -f %{buildroot}%{_libdir}/e2fsprogs/e2scrub_all_cron
111
112%ifarch i686
113rm -rf %{buildroot}%{_unitdir}/e2scrub*
114%endif
115
116%check
117make fullcheck
118
119%ldconfig_scriptlets
120
121%post devel
122if [ -f %{_infodir}/libext2fs.info.gz ]; then
123   /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
124fi
125
126%preun devel
127if [ $1 = 0 -a -f %{_infodir}/libext2fs.info.gz ]; then
128   /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
129fi
130exit 0
131
132%files -f %{name}.lang
133%doc README RELEASE-NOTES
134%license NOTICE
135%config(noreplace) /etc/mke2fs.conf
136%config(noreplace) /etc/e2scrub.conf
137%{_bindir}/chattr
138%{_bindir}/fuse2fs
139%{_bindir}/lsattr
140%{_libdir}/e2fsprogs/e2scrub_fail
141%{_libdir}/libe2p.so.*
142%{_libdir}/libext2fs.so.*
143%{_libdir}/libcom_err.so.*
144%{_libdir}/libss.so.*
145%{_sbindir}/*
146%{_udevrulesdir}/*.rules
147%ifnarch i686
148%{_unitdir}/e2scrub*
149%endif
150
151%files devel
152%{_bindir}/compile_et
153%{_bindir}/mk_cmds
154%{_datadir}/et
155%{_datadir}/ss
156%{_infodir}/libext2fs.info*
157%{_includedir}/e2p
158%{_includedir}/ext2fs
159%{_includedir}/et
160%{_includedir}/com_err.h
161%{_includedir}/ss
162%{_libdir}/pkgconfig/*.pc
163%{_libdir}/*.so
164%{_libdir}/*.a
165
166%files help
167%{_mandir}/man1/*
168%{_mandir}/man3/*
169%{_mandir}/man5/*
170%{_mandir}/man8/*
171
172%changelog
173* Thu Dec 1 2022 Zhiqiang Liu <liuzhiqiang26@huawei.com> - 1.46.4-17
174- fix deadlock problem in unix_write_blk64
175
176* Fri Oct 14 2022 Zhiqiang Liu <liuzhiqiang26@huawei.com> - 1.46.4-16
177- tune2fs: fix segfault problem
178
179* Fri Sep 23 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-15
180- test: fix ACL-printing tests from community
181
182* Sat Aug 20 2022 Zhiqiang Liu <liuzhiqiang26@huawei.com> - 1.46.4-14
183- debugfs: teach logdump the -n <num_trans> option
184
185* Fri Aug 12 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-13
186- tune2fs: do not change j_tail_sequence in journal superblock
187
188* Fri Jun 24 2022 wuzx<wuzx1226@qq.com> - 1.46.4-12
189- add sw64 patch
190
191* Tue Jun 21 2022 lihaoxiang <lihaoxiang9@huawei.com> - 1.46.4-11
192- DESC:add wrapper header file for i686 and x86_64 then fix conflicts when intall i686 rpms.
193
194* Sat May 28 2022 Zhiqiang Liu <liuzhiqiang26@huawei.com> - 1.46.4-10
195- fix CVE-2022-1304
196
197* Fri May 20 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-9
198- e2fsck: handle->level is overflow in ext2fs_extent_get.
199
200* Wed May 18 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-8
201- e2fsck: do not clean up file acl if the inode is truncating type
202
203* Thu Mar 17 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-7
204- tests: skip m_rootdir_acl if selinux is not disabled
205
206* Wed Mar 9 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-6
207- libext2fs: don't old the CACHE_MTX while doing I/O
208
209* Tue Mar 8 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-5
210- tests: update expect file for u_direct_io
211
212* Wed Mar 2 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-4
213- e2mmpstatus.8.in: detele filesystem can be UUID or LABEL in manpage
214
215* Thu Feb 24 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-3
216- adapt patchs from openEuler-20.03-LTS
217
218* Thu Jan 27 2022 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-2
219- replace License in spec
220
221* Sat Nov 27 2021 zhanchengbin <zhanchengbin1@huawei.com> - 1.46.4-1
222- update package to v1.46.4.
223
224* Mon Nov 15 2021 zhanchengbin <zhanchengbin1@huawei.com> - 1.45.6-7
225- DESC: integrate community patches.
226
227* Mon Sep 13 2021 lixiaokeng <lixiaokeng@huawei.com> - 1.45.6-6
228- DESC: add newer libreadline.so.8 to dlopen path
229
230* Fri Aug 20 2021 chenyanpanHW <chenyanpan@huawei.com> - 1.45.6-5
231- DESC: add necessary BuildRequires audit
232
233* Fri Jul 30 2021 chenyanpanHW <chenyanpan@huawei.com> - 1.45.6-4
234- DESC: delete -Sgit from %autosetup, and delete BuildRequires git
235
236* Wed Dec 16 2020 yanglongkang <yanglongkang@huawei.com> - 1.45.6-3
237- Set help package as install require
238
239* Fri Oct 30 2020 Zhiqiang Liu <lzhq28@mail.ustc.edu.cn> - 1.45.6-2
240- backport upstream patches-epoch2 to fix some problems
241
242* Wed Jul 15 2020 Zhiqiang Liu <lzhq28@mail.ustc.edu.cn> - 1.45.6-1
243- rebuild package
244
245* Wed Jul 1 2020 Wu Bo <wubo009@163.com> - 1.45.3-5
246- rebuild package
247
248* Mon Feb 3 2020 luoshijie <luoshijie1@huawei.com> - 1.45.3-4
249- Type:cves
250- ID:CVE-2019-5094
251- SUG:restart
252- DESC:backport patch to fix CVE-2019-5094.
253
254* Wed Jan 22 2020 openEuler Buildteam <buildteam@openeuler.org> - 1.45.3-3
255- Type:bugfix
256- ID:NA
257- SUG:NA
258- DESC:change path to remove no used file.
259
260* Wed Jan 22 2020 openEuler Buildteam <buildteam@openeuler.org> - 1.45.3-2
261- Type:bugfix
262- ID:NA
263- SUG:NA
264- DESC:fix local rpmbuild error.
265
266* Tue Jan 14 2020 openEuler Buildteam <buildteam@openeuler.org> - 1.45.3-1
267- Type:cves
268- ID:CVE-2019-5188
269- SUG:restart
270- DESC:backport patch to fix CVE-2019-5188.
271
272* Tue Jan 14 2020 openEuler Buildteam <buildteam@openeuler.org> - 1.45.3-0
273- Type:enhancement
274- ID:NA
275- SUG:NA
276- DESC:update package from 1.44.3 to 1.45.3.
277
278* Mon Jan 13 2020 openEuler Buildteam <buildteam@openeuler.org> - 1.44.3-8
279- Type:enhancement
280- ID:NA
281- SUG:NA
282- DESC:update spec.
283
284* Wed Sep 18 2019 luoshijie <luoshijie1@huawei.com> - 1.44.3-7
285- Type:bugfix
286- ID:NA
287- SUG:NA
288- DESC:modify spec file to follow spec rules.
289
290* Fri Sep 6 2019 luoshijie <luoshijie1@huawei.com> - 1.44.3-6
291- Type:bugfix
292- ID:NA
293- SUG:NA
294- DESC:openEuler Debranding
295
296* Tue Aug 20 2019 luoshijie <luoshijie1@huawei.com> - 1.44.3-5
297- Type:bugfix
298- ID:NA
299- SUG:NA
300- DESC:rename patch name
301
302* Wed Jul 10 2019 zhangyujing <zhangyujing1@huawei.com> - 1.44.3-4
303- Type:bugfix
304- ID:NA
305- SUG:NA
306- DESC:e2freefrag: fix memory leak in scan_online()
307       create_inode: fix potential memory leak in path_append()
308       mke2fs: fix check for absurdly large devices
309
310* Fri Mar 15 2019 zhangyujing <zhangyujing1@huawei.com> - 1.44.3-3
311- Type:bugfix
312- ID:NA
313- SUG:NA
314- DESC:blkid avoid FPE crash when probing a HFS superblock
315       AOSP e2fsdroid Fix crash with invalid command line a
316       e2fsck fix fd leak in reserve_stdio_fds
317       libext2fs fix uninitialized length in rep_strdup
318       tune2fs fix dereference of freed memory after journa
319       libe2p avoid segfault when s_nr_users is too high
320       e2freefrag fix free blocks count during live scan
321
322* Wed Jan 23 2019 wangxiao <wangxiao65@huawei.com> - 1.44.3-2
323- Type:bugfix
324- ID:NA
325- SUG:NA
326- DESC:disable the metadata_csum creat by mke2fs -t ext4 by default
327- Package init
328
329