• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1Source: bcc
2Maintainer: Brenden Blanco <bblanco@plumgrid.com>
3Section: misc
4Priority: optional
5Standards-Version: 3.9.5
6Build-Depends: debhelper (>= 9), cmake,
7    libllvm3.7 [!arm64] | libllvm3.8 [!arm64] | libllvm6.0,
8    llvm-3.7-dev [!arm64] | llvm-3.8-dev [!arm64] | llvm-6.0-dev,
9    libclang-3.7-dev [!arm64] | libclang-3.8-dev [!arm64] | libclang-6.0-dev,
10    clang-format | clang-format-3.7 [!arm64] | clang-format-3.8 [!arm64] | clang-format-6.0,
11    libelf-dev, bison, flex, libfl-dev, libedit-dev, zlib1g-dev, git,
12    python (>= 2.7), python-netaddr, python-pyroute2, luajit,
13    libluajit-5.1-dev, arping, inetutils-ping | iputils-ping, iperf, netperf,
14    ethtool, devscripts, python3, dh-python
15Homepage: https://github.com/iovisor/bcc
16
17Package: libbcc
18Architecture: all
19Depends: libc6, libstdc++6, libelf1
20Description: Shared Library for BPF Compiler Collection (BCC)
21 Shared Library for BPF Compiler Collection to control BPF programs
22 from userspace.
23
24Package: libbcc-examples
25Architecture: any
26Depends: libbcc (= ${binary:Version})
27Description: Examples for BPF Compiler Collection (BCC)
28
29Package: python-bcc
30Architecture: all
31Depends: libbcc (= ${binary:Version}), python, binutils
32Description: Python wrappers for BPF Compiler Collection (BCC)
33
34Package: python3-bcc
35Architecture: all
36Depends: libbcc (= ${binary:Version}), python3, binutils
37Description: Python3 wrappers for BPF Compiler Collection (BCC)
38
39Package: bcc-tools
40Architecture: all
41Depends: python-bcc (= ${binary:Version})
42Description: Command line tools for BPF Compiler Collection (BCC)
43
44Package: bcc-lua
45Architecture: all
46Depends: libbcc (= ${binary:Version})
47Description: Standalone tool to run BCC tracers written in Lua
48