• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 // RUN: %clang_cc1 -verify %s
2 
f0a(void)3 void f0a(void) {
4    inline void f1(); // expected-error {{inline declaration of 'f1' not allowed in block scope}}
5 }
6 
f0b(void)7 void f0b(void) {
8    void f1();
9 }
10 
11 // FIXME: Add test for "If the inline specifier is used in a friend declaration,
12 // that declaration shall be a definition or the function shall have previously
13 // been declared inline.
14