• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 // RUN: %clang_cc1 -std=c++1z -verify %s
2 
3 inline int f(); // ok
4 inline int n; // ok
5 
6 inline typedef int t; // expected-error {{'inline' can only appear on functions and non-local variables}}
7 inline struct S {}; // expected-error {{'inline' can only appear on functions and non-local variables}}
8 inline struct T {} s; // ok
9