• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 //===----------------------------------------------------------------------===//
2 //
3 //                     The LLVM Compiler Infrastructure
4 //
5 // This file is dual licensed under the MIT and the University of Illinois Open
6 // Source Licenses. See LICENSE.TXT for details.
7 //
8 //===----------------------------------------------------------------------===//
9 
10 // <utility>
11 
12 // template <class T1, class T2> struct pair
13 
14 // template <class T1, class T2> void swap(pair<T1, T2>& x, pair<T1, T2>& y);
15 
16 #include <utility>
17 #include <cassert>
18 
main()19 int main()
20 {
21     {
22         typedef std::pair<int, short> P1;
23         P1 p1(3, static_cast<short>(4));
24         P1 p2(5, static_cast<short>(6));
25         swap(p1, p2);
26         assert(p1.first == 5);
27         assert(p1.second == 6);
28         assert(p2.first == 3);
29         assert(p2.second == 4);
30     }
31 }
32