• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 // RUN: %clang_cc1 -fsyntax-only -verify %s
2 // expected-no-diagnostics
3 
4 template<class T> class Array { /* ... */ };
5 template<class T> void sort(Array<T>& v);
6 
7 // explicit specialization for sort(Array<int>&)
8 // with deduced template-argument of type int
9 template<> void sort(Array<int>&);
10