• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1From 1153211a5615156f450a4f521da284a7df4d4e5f Mon Sep 17 00:00:00 2001
2From: Abhishek Pandit-Subedi <abhishekpandit@google.com>
3Date: Mon, 14 Feb 2022 14:40:41 -0800
4Subject: [PATCH] Fix build issues on 930012
5
6---
7 BUILD.gn            | 1 +
8 base/command_line.h | 1 +
9 2 files changed, 2 insertions(+)
10
11diff --git a/libchrome/BUILD.gn b/libchrome/BUILD.gn
12index 292c08565a..dbe3fb0981 100644
13--- a/libchrome/BUILD.gn
14+++ b/libchrome/BUILD.gn
15@@ -42,6 +42,7 @@ config("libchrome_config") {
16     "-Wno-unreachable-code-return",
17     "-Wno-unused-local-typedefs",
18     "-Xclang-only=-Wno-char-subscripts",
19+    "-Wno-implicit-int-float-conversion",
20   ]
21
22   # Address sanitizer + coverage builds do not support -z,defs.
23diff --git a/libchrome/base/command_line.h b/libchrome/base/command_line.h
24index 706726a73e..ad0281283a 100644
25--- a/libchrome/base/command_line.h
26+++ b/libchrome/base/command_line.h
27@@ -19,6 +19,7 @@
28 #include <stddef.h>
29 #include <functional>
30 #include <map>
31+#include <memory>
32 #include <string>
33 #include <vector>
34
35--
362.35.1.265.g69c8d7142f-goog
37
38