• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1bcc (0.24.0-1) unstable; urgency=low
2
3  * Support for kernel up to 5.16
4  * bcc tools: update for trace.py, sslsniff.py, tcptop.py, hardirqs.py, etc.
5  * new libbpf tools: bashreadline
6  * allow specify wakeup_events for perf buffer
7  * support BPF_MAP_TYPE_{INODE, TASK}_STORAGE maps
8  * remove all deprecated libbpf function usage
9  * remove P4/B language support
10  * major test infra change, using github actions now
11  * doc update, bug fixes and other tools improvement
12
13 -- Yonghong Song <ys114321@gmail.com>  Wed, 14 Jan 2022 17:00:00 +0000
14
15bcc (0.23.0-1) unstable; urgency=low
16
17  * Support for kernel up to 5.15
18  * bcc tools: update for kvmexit.py, tcpv4connect.py, cachetop.py, cachestat.py, etc.
19  * libbpf tools: update for update for mountsnoop, ksnoop, gethostlatency, etc.
20  * fix renaming of task_struct->state
21  * get pid namespace properly for a number of tools
22  * initial work for more libbpf utilization (less section names)
23  * doc update, bug fixes and other tools improvement
24
25 -- Yonghong Song <ys114321@gmail.com>  Wed, 15 Nov 2021 17:00:00 +0000
26
27bcc (0.22.0-1) unstable; urgency=low
28
29  * Support for kernel up to 5.14
30  * add ipv4/ipv6 filter support for tcp trace tools
31  * add python interface to attach raw perf events
32  * fix tcpstates for incorrect display of dport
33  * new options for bcc tools runqslower, argdist
34  * new libbpf-tools: filetop, exitsnoop, tcprtt
35  * doc update, bug fixes and other tools improvement
36
37 -- Yonghong Song <ys114321@gmail.com>  Wed, 15 Sep 2021 17:00:00 +0000
38
39bcc (0.21.0-1) unstable; urgency=low
40
41  * Support for kernel up to 5.13
42  * support for debug information from libdebuginfod
43  * finished support for map elements items_*_batch() APIs
44  * add atomic_increment() API
45  * support attach_func() and detach_func() in python
46  * fix displaying PID instead of TID for many tools
47  * new tools: kvmexit.py
48  * new libbpf-tools: gethostlatency, statsnoop, fsdist and solisten
49  * fix tools ttysnoop/readahead for newer kernels
50  * doc update and bug fixes
51
52 -- Yonghong Song <ys114321@gmail.com>  Mon, 16 Jul 2021 17:00:00 +0000
53
54bcc (0.20.0-1) unstable; urgency=low
55
56  * Support for kernel up to 5.12
57  * Some basic support for MIPS
58  * added bpf_map_lookup_batch and bpf_map_delete_batch support
59  * tools/funclatency.py support nested or recursive functions
60  * tools/biolatency.py can optionally print out average/total value
61  * fix possible marco HAVE_BUILTIN_BSWAP redefine warning for kernel >= 5.10.
62  * new tools: virtiostat
63  * new libbpf-tools: ext4dist
64  * doc update and bug fixes
65
66 -- Yonghong Song <ys114321@gmail.com>  Mon, 5 May 2021 17:00:00 +0000
67
68bcc (0.19.0-1) unstable; urgency=low
69
70  * Support for kernel up to 5.11
71  * allow BCC as a cmake subproject
72  * add LPORT support in tcpconnlat and tcpconnect
73  * added bpf_map_lookup_and_delete_batch support
74  * new tools: virtiostat
75  * new libbpf-tools: cpufreq, funclatency, cachestat
76  * add install target to libbpf-tools
77  * a few lua fixes
78  * doc update and bug fixes
79
80 -- Yonghong Song <ys114321@gmail.com>  Mon, 19 Mar 2021 17:00:00 +0000
81
82bcc (0.18.0-1) unstable; urgency=low
83
84  * Support for kernel up to 5.10
85  * add bpf kfunc/kretfunc C++ example
86  * add PT_REGS_PARMx_SYSCALL helper macro
87  * biolatency: allow json output
88  * biolatpcts: support measuring overall latencies between two events
89  * fix build when ENABLE_CLANG_JIT is disabled
90  * doc update and bug fixes
91
92 -- Yonghong Song <ys114321@gmail.com>  Mon, 4 Jan 2021 17:00:00 +0000
93
94bcc (0.17.0-1) unstable; urgency=low
95
96  * Support for kernel up to 5.9
97  * usdt: add uprobe refcnt support
98  * use newer llvm/clang versions in debian packaging if possible
99  * add bpf iterator C++ support
100  * new bcc tools: tcprtt, netqtop, swapin, tcpsynbl, threadsnoop
101  * tcpconnect: add DNS correlation to connect tracking
102  * new libbpf-tools: llcstat, numamove, runqlen, runqlat, softirgs, hardirqs
103  * doc update, bug fixes and some additional arguments for tools
104
105 -- Yonghong Song <ys114321@gmail.com>  Thu, 29 Oct 2020 17:00:00 +0000
106
107bcc (0.16.0-1) unstable; urgency=low
108
109  * Support for kernel up to 5.8
110  * trace.py: support kprobe/uprobe func offset
111  * support raw perf config for perf_event_open in python
112  * add BPFQueueStackTable support
113  * added Ringbuf support support
114  * libbpf-tools: readahead, biosnoop, bitesize, tcpconnlat, biopattern, biostacks
115  * bug fixes and some additional arguments for tools
116
117 -- Yonghong Song <ys114321@gmail.com>  Sat, 22 Aug 2020 17:00:00 +0000
118
119bcc (0.15.0-1) unstable; urgency=low
120
121  * Support for kernel up to 5.7
122  * new tools: funcinterval.py, dirtop.py
123  * support lsm bpf programs
124  * support multiple pid/tids for offwaketime
125  * usdt: add helpers to set semaphore values
126  * turn off x86 jump table optimization during jit compilation
127  * add support to use bpf_probe_read[_str_}{_user,kernel} in all bpf
128  *    programs, fail back to old bpf_probe_read[_str] for old kernels
129  * tools: add filtering by mount namespace
130  * libbpf-tools: cpudist, syscount, execsnoop, vfsstat
131  * lots of bug fixes and a few additional arguments for tools
132
133 -- Yonghong Song <ys114321@gmail.com>  Mon, 19 Jun 2020 17:00:00 +0000
134
135bcc (0.14.0-1) unstable; urgency=low
136
137  * Support for kernel up to 5.6
138  * new tools: biolatpcts.py
139  * libbpf-tools: tools based on CORE and libbpf library directly
140  * add --cgroupmap to various tools, filtering based cgroup
141  * support kfunc (faster kprobe) for vfsstat, klockstat and opensnoop
142  * lots of bug fixes and a few additional arguments for tools
143
144 -- Yonghong Song <ys114321@gmail.com>  Mon, 20 Apr 2020 17:00:00 +0000
145
146bcc (0.13.0-1) unstable; urgency=low
147
148  * Support for kernel up to 5.5
149  * bindsnoop tool to track tcp/udp bind information
150  * added compile-once run-everywhere based libbpf-tools, currently
151    only runqslower is implemented.
152  * new map support: sockhash, sockmap, sk_storage, cgroup_storage
153  * enable to run github actions on the diff
154  * cgroupmap based cgroup filtering for opensnoop, execsnoop and bindsnoop.
155  * lots of bug fixes.
156
157 -- Yonghong Song <ys114321@gmail.com>  Wed, 19 Feb 2020 17:00:00 +0000
158
159bcc (0.12.0-1) unstable; urgency=low
160
161  * Support for kernel up to 5.4
162  * klockstat tool to track kernel mutex lock statistics
163  * cmake option CMAKE_USE_LIBBPF_PACKAGE to build a bcc shared library
164    linking with distro libbpf_static.a
165  * new map.lookup_or_try_init() API to remove hidden return in
166    map.lookup_or_init()
167  * BPF_ARRAY_OF_MAPS and BPF_HASH_OF_MAPS support
168  * support symbol offset for uprobe in both C++ and python API,
169    kprobe already has the support
170  * bug fixes for trace.py, tcpretrans.py, runqslower.py, etc.
171
172 -- Yonghong Song <ys114321@gmail.com>  Tue, 10 Dec 2019 17:00:00 +0000
173
174bcc (0.11.0-1) unstable; urgency=low
175
176  * Support for kernel up to 5.3
177  * Corresponding libbpf submodule release is v0.0.5
178  * Fix USDT issue with multi-threaded applications
179  * Fixed the early return behavior of lookup_or_init
180  * Support for nic hardware offload
181  * Fixed and Enabled Travis CI
182  * A lot of tools change with added new options, etc.
183
184 -- Yonghong Song <ys114321@gmail.com>  Tue, 03 Oct 2019 17:00:00 +0000
185
186bcc (0.10.0-1) unstable; urgency=low
187
188  * Support for kernel up to 5.1
189  * corresponding libbpf submodule release is v0.0.3
190  * support for reading kernel headers from /proc
191  * libbpf.{a,so} renamed to libcc_bpf.{a,so}
192  * new common options for some tools
193  * new tool: drsnoop
194  * s390 USDT support
195
196 -- Brenden Blanco <bblanco@gmail.com>  Tue, 28 May 2019 17:00:00 +0000
197
198bcc (0.9.0-1) unstable; urgency=low
199
200  * Adds support for BTF
201  * Uses libbpf common library to wrap syscall API
202  * Many bugfixes and new tools
203
204 -- Brenden Blanco <bblanco@gmail.com>  Thu, 07 Mar 2019 17:00:00 +0000
205
206bcc (0.8.0-1) unstable; urgency=low
207
208  * Support for kernel up to 5.0
209
210 -- Brenden Blanco <bblanco@gmail.com>  Fri, 11 Jan 2019 17:00:00 +0000
211
212bcc (0.7.0-1) unstable; urgency=low
213
214  * Support for kernel up to 4.18
215
216 -- Brenden Blanco <bblanco@gmail.com>  Tue, 04 Sep 2018 17:00:00 +0000
217
218bcc (0.6.1-1) unstable; urgency=low
219
220  * Build support for Fedora 28 and Ubuntu 18.04
221  * Add option to change license
222  * Optimizations for some uses of bpf_probe_reads
223
224 -- Brenden Blanco <bblanco@gmail.com>  Mon, 23 Jul 2018 17:00:00 +0000
225
226bcc (0.6.0-1) unstable; urgency=low
227
228  * Support for kernel up to 4.17
229  * Many bugfixes
230  * Many new tools
231  * Improved python3 support
232
233 -- Brenden Blanco <bblanco@gmail.com>  Wed, 13 Jun 2018 17:00:00 +0000
234
235bcc (0.5.0-1) unstable; urgency=low
236
237  * Support for USDT in ARM64
238  * Bugfixes for 4.14 in some tools
239  * Fixes for smoke test failures
240  * Runtime memory usage reductions
241
242 -- Brenden Blanco <bblanco@gmail.com>  Wed, 29 Nov 2017 17:00:00 +0000
243
244bcc (0.4.0-1) unstable; urgency=low
245
246  * Bugfixes
247  * Support for kernel up to 4.14
248
249 -- Brenden Blanco <bblanco@gmail.com>  Fri, 20 Oct 2017 17:00:00 +0000
250
251bcc (0.3.0-1) unstable; urgency=low
252
253  * Many bugfixes
254  * Many tools converted to perf ring buffer
255  * New utilities in tools/
256   * capable, cpuunclaimed, dbslower, dbstat, deadlock_detector, llcstat,
257     mountsnoop, runqlen, slabratetop, syscount, tcplife, tcptop, ttysnoop,
258     ucalls, uflow, ugc, uobjnew, ustat, uthreads
259  * New C++ API
260  * Support for kernel up to 4.10
261
262 -- Brenden Blanco <bblanco@gmail.com>  Thu, 09 Mar 2017 19:08:08 +0000
263
264bcc (0.2.0-1) unstable; urgency=low
265
266  * Add many new utilities in tools/
267  * Support for USDT
268  * Support for lua
269  * Many utilities converted to perf ring buffer
270  * Support for tracepoints
271
272 -- Brenden Blanco <bblanco@plumgrid.com>  Thu, 08 Sep 2016 17:05:28 -0700
273
274bcc (0.1.8-1) unstable; urgency=low
275
276  * Add many new utilities in tools/
277   * wakeuptime, offwaketime, argdist, {xfs,zfs,ext4}{slower,dist}, others
278  * Support for bpf_perf_event()
279  * Support for public tables shared between programs
280  * Support for up to 4.4 features
281  * Remove external file dependencies from clang lib
282
283 -- Brenden Blanco <bblanco@plumgrid.com>  Mon, 23 Feb 2016 00:41:00 +0000
284
285bcc (0.1.7-1) unstable; urgency=low
286
287  * Tracing features and bugfixes
288  * Built against LLVM 3.8 HEAD
289
290 -- Brenden Blanco <bblanco@plumgrid.com>  Mon, 12 Oct 2015 16:47:09 +0000
291
292bcc (0.1.6-1) unstable; urgency=low
293
294  * Stability fixes
295  * Improvements to python API
296  * Tracing features
297  * Support for kernel 4.2 features
298
299 -- Brenden Blanco <bblanco@plumgrid.com>  Wed, 02 Sep 2015 16:23:19 +0000
300
301bcc (0.1.5-1) unstable; urgency=low
302
303  * Initial release
304
305 -- Brenden Blanco <bblanco@plumgrid.com>  Mon, 06 Jul 2015 18:04:28 +0000
306