• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1# New ports collection makefile for:   clearsilver
2# Date created:        13 April 2003
3# Whom:                Brandon Long <blong@fiction.net>
4#
5# $FreeBSD$
6#
7
8PORTNAME=      clearsilver
9PORTVERSION=   0.9.7
10CATEGORIES=    www python perl ruby
11DISTDIR=       /home/blong/ports/distfiles
12MASTER_SITES=  http://www.clearsilver.net/downloads/
13
14MAINTAINER=    blong@fiction.net
15COMMENT=       ClearSilver is a fast, powerful, and language-neutral HTML template system.
16
17.if defined(PACKAGE_BUILDING)
18WITH_PERL=	yes
19WITH_PYTHON=	yes
20.endif
21
22.if defined(WITH_PYTHON)
23USE_PYTHON=	yes
24.endif
25
26.if defined(WITH_PERL)
27USE_PERL5=	yes
28.endif
29
30.if defined(WITH_RUBY)
31USE_RUBY=	yes
32.endif
33
34GNU_CONFIGURE= yes
35USE_GMAKE=     yes
36
37.include <bsd.port.mk>
38