1 // RUN: %clang_cc1 %s -std=c++11 -triple=x86_64-apple-darwin10 -emit-llvm -o - -fcxx-exceptions -fexceptions | FileCheck %s
2
3 void external();
4
target()5 void target() noexcept
6 {
7 // CHECK: invoke void @_Z8externalv()
8 external();
9 }
10 // CHECK: landingpad { i8*, i32 } personality i8* bitcast (i32 (...)* @__gxx_personality_v0 to i8*)
11 // CHECK-NEXT: catch i8* null
12 // CHECK-NEXT: call void @_ZSt9terminatev() noreturn nounwind
13 // CHECK-NEXT: unreachable
14
reverse()15 void reverse() noexcept(false)
16 {
17 // CHECK: call void @_Z8externalv()
18 external();
19 }
20