• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 // RUN: %clang_cc1 -std=c++11 -fexceptions -fcxx-exceptions -fsyntax-only -verify %s
2 // expected-no-diagnostics
3 
4 // This is the "let the user shoot himself in the foot" clause.
f()5 void f() noexcept {
6   throw 0; // no-error
7 }
g()8 void g() throw() {
9   throw 0; // no-error
10 }
h()11 void h() throw(int) {
12   throw 0.0; // no-error
13 }
14