• Home
  • Line#
  • Scopes#
  • Navigate#
  • Raw
  • Download
1 // RUN: %clang_cc1 -std=c++1y -fsyntax-only -verify %s
2 
3 // -- The argument list of the specialization shall not be identical
4 //    to the implicit argument list of the primary template.
5 
6 template<typename T, int N, template<typename> class X> int v1;
7 template<typename T, int N, template<typename> class X> int v1<T, N, X>;
8 // expected-error@-1{{variable template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
9 
10 template<typename...T> int v2;
11 template<typename...T> int v2<T...>;
12 // expected-error@-1{{variable template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
13 
14 template<int...N> int v3;
15 template<int...N> int v3<N...>;
16 // expected-error@-1{{variable template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
17 
18 template<template<typename> class...X> int v4;
19 template<template<typename> class...X> int v4<X...>;
20 // expected-error@-1{{variable template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
21 
22 template<typename Outer> struct X {
23   template<typename Inner> static int y;
24   template<typename Inner> static int y<Outer>; // expected-warning {{cannot be deduced}} expected-note {{'Inner'}}
25   template<typename Inner> static int y<Inner>; // expected-error {{does not specialize}}
26 };
27 template<typename Outer> template<typename Inner> int X<Outer>::y<Outer>; // expected-warning {{cannot be deduced}} expected-note {{'Inner'}}
28 template<typename Outer> template<typename Inner> int X<Outer>::y<Inner>; // expected-error {{does not specialize}}
29 
30 // FIXME: Merging this with the above class causes an assertion failure when
31 // instantiating one of the bogus partial specializations.
32 template<typename Outer> struct Y {
33   template<typename Inner> static int y;
34 };
35 template<> template<typename Inner> int Y<int>::y<Inner>; // expected-error {{does not specialize}}
36